Duplicator WP Plugin & Digital Ocean

January 9, 2015 3.8k views

Hello,

I have been struggling for a few days now to launch my clients new website on my droplet. I have a site fully built on wordpress on a local server and I exported the site using the Duplicator WP plugin. I uploaded the installer.php and zip package via FTP onto the server. Usually when using other hosting services PHPmyadmin and MySQL are preinstalled.

I have read online a lot and have come to the conclusion that I need to install a LAMP stack. During attempting to do this following these two tutorials:

1) https://www.digitalocean.com/community/tutorials/how-to-migrate-wordpress-from-shared-hosting-to-a-cloud-server-with-zero-downtime
2) https://www.digitalocean.com/community/tutorials/how-to-install-linux-apache-mysql-php-lamp-stack-on-ubuntu

When installing LAMP and executing the code "sudo /usr/bin/mysqlsecureinstallation" my command line keeps saying "ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)" and I have reset the root password and tried every combination of passwords and nothing seems to be working.

Long story short, I have deployed my installer.php and my zip file into var/www/ and I need to have this site live today. I have installed Duplicator WP on my current default Wordpress setup to "restore" it as many have said online and I can't seem to find this file.

Please help!

8 comments
  • Hi SolidRock.

    for the moment, just forget about the Duplicator plugin.

    do you have phpmyadmin installed and working?
    do you have Wordpress installed and working?

    on your local server, can you do a MySQL dump of your wordpress database?

  • I do not have phpmyadmin installed or working.

    I have MySQL working in the command line when I SSH into the droplet but as I stated above, installing LAMP has given me multiple issues with root access.

    Wordpress was installed using one-click when setting up droplet on Ubuntu image. The current website is http://solidrock.bluedashmedia.com and is hosted on a Hostgator Hosting account.

    How can I go about installing phpmyadmin and dumping the database?

  • if you have access to command-line you could just do:

    sudo apt-get install phpmyadmin
    
  • Ok so now I have phpmyadmin at my disposal. It is asking me to select apache2 or lighttpd. Apologies in advance, this is my first time installing a php database via command line. I usually have a GUI. When you say dump my database, do you mean export my mysql tables? Would love more details or tutorials as my client is on edge and I need this done asap.

    Thanks so much for the help so far sierracircle!

  • Yes, dump and export are pretty much the same thing. in phpMyadmin you can export or import a database (or even just single tables..)

    So, if you get a bare-bones Wordpress installed on your droplet, you can then empty that database (drop all tables) and then import your dump from your development server.

    You would then need to upload any themes and plugins you need.

    Final steps would be to update the URL to the correct domain, and then finally run a plugin called Velvet Blues URL updater, which will clean up any broken links.

  • I'm just going through this same problem, if anyone can help. I used this plugin, but** in MySQL Database** But I do not know any of this information - I already know the password MySql default, *(/root/.my.cnf) * but not connected and I've tried resetting and also will not conect and not reset password... Thanks.

  • In my case** I already have installed the LAMP and PHPMyAdmin working and backup my database.sql. What should I do, **only export this database.sql using PHPMyAdmin? but what the password and host use in my old database?

  • Dear KWsolidrock, already resolved can tell me how? Thanks.

6 Answers

Dear KWsolidrock, already resolved can tell me how? Thanks.

I'm just going through this same problem, if anyone can help. I used this plugin, but** in MySQL Database** But I do not know any of this information - I already know the password MySql default, *(/root/.my.cnf) * but not connected and I've tried resetting and also will not conect and not reset password... Thanks.

In my case** I already have installed the LAMP and PHPMyAdmin working and backup my database.sql. What should I do, **only export this database.sql using PHPMyAdmin? but what the password and host use in my old database?

After several errors i got it import, but I'm with my doubts because DB had the name of my BLOG.SQL, the DROPLET installed Wrodpress create a DB with WordPress.SQL name. When I imported it automatically** MERGE?** because it was all mixed up the database, see in the image below

http://postimg.org/image/9qhyj6ipr/

How to rename the tables that indicated in RED, I want remove this: wp_696xx5w6nk I do not know how to godaddy created this ...

Stumbled upon this - while it is a bit late here is an easy solution.

I use sentora cpanel from sentora.org.

While it is currently not ready for client use, in my opinion, it makes life really easy on a droplet.
Steps:
1) have a domain for the "hosting" can be something as simple as a dtdns account subdomain. lets call it xyz.com
2) Create a fresh Ubantu 14.xx droplet with the name identical to your chosen domain name - you need this for the ptr record
2a) Point xyz.com to your droplet
3) update and upgrade the droplet
4) Go to sentora.org and read the current install instructions
5) Copy the install command and paste it into your ssh session to the droplet.
6) set the cpanel subdomain to xyz.com in the setup script ie cpanel.xyz.com - then Follow the bouncing ball..
7) Set up firewall minimal ports
8) Login to the cpanel.xyz.com as zadmin- password displayed at end of install script
9) Create an account for your customer
10) log to your customers account
11) use customers account to create DB and User and then add the customers domain to host the wordpress site (may take a while to propagate - change customers domain named servers to point to the droplet)
12)create customer ftp account
13)ftp the duplicator files up to the customers domain root
14) open browser and run installer and give the appropriate details.
Wordpress is now live

Hope this helps - should take about 15 mins (after domains are available) excluding upload times

Additional suggestion is to add swap to the droplet.
I tend to use cloudflare and set up both the "hosting" and the customers domain ready to switch to the droplet. this may take 24 hrs (though usually 1 hr) then switch-over to the droplet is almost instantaneous.

I do this sort of thing for run and profit.. PM me if you want assistance.

.

Have another answer? Share your knowledge.