Question

Fedora 26 Server: Node.js app hangs forever when not launched directly

I’ve tried to launch a Node.js app either with systemd or cron both with unprivileged and privileged accounts but it seems that the only way to get it work is with node app.js or whatever_monitoring_package app.js. I’m using nginx as a reverse proxy, so my first guess was to check if nginx’s logs had some errors but nothing. Then I tried to launch it directly by http://IP:PORT but nothing. My firewall’s rules are ok, triple-checked. Browsers say “Waiting…”. systemd works normally and cron is normally executed at startup. There are no errors.

Thanks in advance.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@Gabriele Romanato

Check this tutorial for running Nodejs apps.

Hope this helps