Question

FreeBSD, Portsnap, and Bind10

Posted February 25, 2015 2.3k views
===>  bind10-1.2.0_2 You have python 2.7 set as the default, and this needs 3.4.

Trying to make clean install and running into this error. I have python 3.4 installed and can’t get around this.

I can install bind910 without issue but bind10 is unworkable.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

EDIT: Nevermind moving to bundy

In case someone else has the same issue, it looks like the error is saying that the Default python needs to be 3.4. This should just be fixable by the symlink juggle.

Your symlink is probably already set for 2.7 to point to ‘python’. delete the link, create a new:

rm /usr/local/bin/python
ln -s /usr/local/bin/python3.4  /usr/local/bin/python
Submit an Answer