Question

Ghost blog up after ubuntu upgrade

I upgrade to from 12.04 to 14.04. Now the nginx page comes up instead of my ghost blog. I went back and make sure ghost was running. I can see node and ghost running so I am unsure what when wrong.

Any thoughts?

Thanks


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hey Seth, <br> <br>I was just able to reproduce this starting with a Ghost droplet and upgrading it to 14.04 The configuration isn’t being overwritten, but for some reason /etc/nginx/conf.d/default.conf isn’t loaded. The fix is easy enough though. <br> <br>Open the file “/etc/nginx/sites-enabled/default” and find the section that looks like <br> <br><pre> <br> location / { <br> # First attempt to serve request as file, then <br> # as directory, then fall back to displaying a 404. <br> try_files $uri $uri/ =404; <br> # Uncomment to enable naxsi on this location <br> # include /etc/nginx/naxsi.rules <br> #} <br></pre> <br> <br>replace it with the following: <br> <br><pre> <br> location / { <br> proxy_set_header X-Real-IP $remote_addr; <br> proxy_set_header HOST $http_host; <br> proxy_set_header X-NginX-Proxy true; <br> <br> proxy_pass http://127.0.0.1:2368; <br> proxy_redirect off; <br> } <br></pre> <br> <br>Finally, restart nginx using the command <br> <br><pre>service nginx restart</pre> <br> <br>Ghost show now be available again. Let us know how it goes! <br> <br>

Your nginx config file was probably reset. Did you follow a tutorial to install Ghost? If so, just follow the parts that deal with nginx’s config file again.