GitLab 6.3 CE Droplet - SSH Push fails

Posted December 3, 2013 6.3k views
Pushing to a fresh install of gitlab with the application image from DigitalOcean fails with Access denied. fatal: Could not read from remote repository. Please make sure you have the correct access rights and the repository exists. I used the DigitalOcean guide to setup the installation:

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
5 answers
Did you add your public ssh key to your user using GitLab?
yes, I did.
I tried my existing key and created a new key. No luck.
I've just tried pushing to a gitlab repo and it worked (fresh GitLab droplet). What command are you trying to run?
git push -u origin master

I also tried Git-Tower (Git-Client for Mac) => same issue

I had this issue, it turned out that the git repository wasn’t being cerated at all in /var/opt/gitlab/git-data/repositories restarting the server fixed it for me, not sure why.

shutdown -r now

  • To add to this it looks like mine was a memory issue. I fixed it for good by adding some swap space. Here’s the tutorial I followed for Ubuntu 14 - How to Add Swap on Ubuntu 14.04

    by Justin Ellingwood
    Swap space can be used as an "overflow" area for your system when you run out of RAM. The operating system can store data that would normally be kept in RAM on the hard drive in a specially formatted file. In this guide, we'll demonstrate how to create and use one of these files in Ubuntu 14.04.