Question

Having too many problems setting up Wordpress on ubuntu 20.04 from marketplace installation.

Posted October 25, 2020 122 views
WordPressUbuntu 20.04

I’m having too many issues setting this up, i’m not sure what recent changes were done to how setting up a wordpress server is but they’ve made it an extreme hassle. I’m about ready to just delete my account and find another server hosting provider.

before I just created the droplet, ssh’d in to install the wordpress and necessary modules and thats it. everything else was mainly done from wp-admin, and I could get there easily. Now I keep getting errors.

The domain keeps going from working perfectly, to going down & me getting an “ERREMPTYRESPONSE” error as well as a ‘Database could not be established’ error when it finally goes back up and I try to visit the site via ip address.

When the site is finally actually working, I try to log into WP admin & the correct password I set does not work. So I try to hit reset. 7 resets and 4 hours later I still have not recieved a new password or password reset link. Can someone please help me figure out whats going on before I just give up on DO? I already have beef due to some other corny shit they did and this isnt helping

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Hi @ABrav,

I’m sorry to hear you are having such a hard time using the Marketplace option. I’ve just tried to recreate what you have been describing however I was able to install WordPress without a problem.

Can I ask you to post step by step what you are doing once you deploy a WordPress droplet? This will help in finding the issue!

Regards,
KFSys

Out of curiosity, how big is your droplet? Also, are you running the DB in the same instance?

The reset password could simply because there is not mail server configured so it never gets sent, so you may want to check you SMTP settings and ensure the ports are open to outbound 25 or whatever port your SMTP is set to.

Next, if you turn on debug do you see errors? Is this a fresh install of WP, so default theme and plugins?

As a side note, can you use the WP cli to reset your password?

Submit an Answer