Question

How come I am unable to install Owncloud Apps on a pre-installed owncloud droplet?

Posted July 8, 2015 2.7k views
UbuntuDigitalOcean 1-Click Apps Marketplace

Hi, I have spun up a preconfigured owncloud droplet. Things were working great, I followed the digital ocean guidelines to secure the installation and get it up and running. My users are able to connect and the owncloud client works fine.

I tried to install an App from the Owncloud “Productivity” section and it fails. Actually, any new app that I try to install fails. Here is a part of the admin log –

Fatal   core    Unable to parse OCS content 2015-07-07T23:07:44+00:00
Fatal   core    Invalid OCS content returned for app 169914 2015-07-07T23:07:43+00:00
Fatal   core    Invalid OCS content returned for app 169914 2015-07-07T23:07:43+00:00
Fatal   core    Invalid OCS content returned for app 168711 2015-07-07T23:07:42+00:00
Fatal   core    Invalid OCS content returned for app 166056 2015-07-07T23:07:41+00:00
Fatal   core    Invalid OCS content returned for app 166054 2015-07-07T23:07:41+00:00
Fatal   core    Invalid OCS content returned for app 166049 2015-07-07T23:07:41+00:00
Fatal   core    Invalid OCS content returned for app 168707 2015-07-07T23:07:40+00:00
Fatal   core    Invalid OCS content returned for app 166052 2015-07-07T23:07:40+00:00
Fatal   core    Invalid OCS content returned for app 166051 2015-07-07T23:07:39+00:00
Fatal   core    Invalid OCS content returned for app 166038 2015-07-07T23:07:39+00:00
Fatal   core    Invalid OCS content returned for app 166055 2015-07-07T23:07:39+00:00
Fatal   core    Invalid OCS content returned for app 166053 2015-07-07T23:07:38+00:00

Aside from some web crawlers trying to look for wordpress, here are the relevant apache logs:

root@dotamastery-owncloud:~# sudo tail -20 /var/log/apache2/error.log
[Mon Jul 06 04:44:12.445757 2015] [:error] [pid 13112] [client 80.146.213.31:35129] script '/var/www/owncloud/wp-login.php' not found or unable to stat
[Mon Jul 06 04:44:13.026479 2015] [:error] [pid 13480] [client 80.146.213.31:35256] script '/var/www/owncloud/admin.php' not found or unable to stat
[Tue Jul 07 07:47:32.552221 2015] [:error] [pid 13528] [client 113.160.142.239:27704] script '/var/www/owncloud/wp-login.php' not found or unable to stat
[Tue Jul 07 16:51:44.126989 2015] [authz_core:error] [pid 13583] [client 45.55.156.70:39307] AH01630: client denied by server configuration: /var/www/owncloud/data/htaccesstest.txt
[Tue Jul 07 16:53:56.487454 2015] [authz_core:error] [pid 12614] [client 45.55.156.70:39354] AH01630: client denied by server configuration: /var/www/owncloud/data/htaccesstest.txt
[Tue Jul 07 16:59:11.348960 2015] [authz_core:error] [pid 18434] [client 45.55.156.70:39429] AH01630: client denied by server configuration: /var/www/owncloud/data/htaccesstest.txt
[Tue Jul 07 17:00:00.299347 2015] [authz_core:error] [pid 18332] [client 45.55.156.70:39432] AH01630: client denied by server configuration: /var/www/owncloud/data/htaccesstest.txt
[Tue Jul 07 17:00:19.821991 2015] [authz_core:error] [pid 18432] [client 45.55.156.70:39434] AH01630: client denied by server configuration: /var/www/owncloud/data/htaccesstest.txt
[Tue Jul 07 17:01:00.169501 2015] [authz_core:error] [pid 13583] [client 45.55.156.70:39456] AH01630: client denied by server configuration: /var/www/owncloud/data/htaccesstest.txt
[Tue Jul 07 17:01:09.100343 2015] [authz_core:error] [pid 13583] [client 45.55.156.70:39458] AH01630: client denied by server configuration: /var/www/owncloud/data/htaccesstest.txt
[Tue Jul 07 17:02:13.743762 2015] [authz_core:error] [pid 18414] [client 45.55.156.70:39479] AH01630: client denied by server configuration: /var/www/owncloud/data/htaccesstest.txt
[Tue Jul 07 18:38:42.506701 2015] [:error] [pid 18501] [client 96.231.37.131:51612] script '/var/www/owncloud/wp-login.php' not found or unable to stat
[Tue Jul 07 19:06:57.295020 2015] [authz_core:error] [pid 18500] [client 45.55.156.70:39497] AH01630: client denied by server configuration: /var/www/owncloud/data/htaccesstest.txt

I have not been able to install any Apps through Owncloud, although enabled the Calendar app just fine.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

I’m not able to reproduce this issue. Judging from this ownCloud bug report, it looks like this was a problem introduced in 8.0.4 but resolved in the meantime.

Submit an Answer