Question

How I set the php mail function for multiple domains correctly?

Hello,

Sometime ago I install the mail (php function), but when I tried to send the email by any HTML form the response was too slow. I solved the problem editting the /etc/hosts file with a correct FQDN.

I am using multiple domains (Virtual Host), and this week when I was installing another site I checked that the mails is sending slow again. How can i fix it again?

My /etc/hosts are:

127.0.0.1 localhost.localdomain localhost
127.0.1.1 rioth.maindomain.me maindomain
162.243.11.116 rioth.maindomain.me maindomain
162.243.11.116 mail.anotherdomain.com mail
162.243.11.116 mail.otherdomain.co mail

Regards,

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

There are a couple ways to accomplish this in sendmail but as you are not using sendmail as part of a fully fledged email server and only to send emails from your web scripts the following should do the trick:

<VirtualHost *:80>
    Standard stuff goes here

    <Directory /dir/to/your/web/root>
        php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fuser@domain2.com"
    </Directory>

</VirtualHost>

Adding this directive to your virtualhosts should set the default sender for the emails sent by your php scripts. In this case it is setting the sender to user@domain2.com for this virtualhost.

Be sure to restart apache after updating your configuration so the change can take effect.