Question

How to enable root login and password authentication trough recovery web console?

Posted December 6, 2018 3.8k views
CentOSControl Panels

Yesterday, I update my cPanel version on my droplet. After update, it says that I have to enable cpHulk. So, I enable it, with a bunch of config that I don’t event understand. The thing that I remember that I disabled root login trough WHM and SSH. I don’t have any other login except root for WHM and SSH.

I did some tutorial that I found:

  1. I reset the root password at DigitalOcean dashboard, and I try to login SSH which is not working.
  2. I reset password and login to WHM, also not working.
  3. I tried to boot from recovery ISO and enable SSH root login, also not working.

And my question: How to enable root login and password authentication trough recovery web console?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
3 answers

What exact steps did you follow to enable SSH root login? What settings did you change?

Cheers

Hello all,

You can also temporary enable the PasswordAuthentication from no to yes in order to access your droplet using a password and then once you’ve entered your key to disable the PasswordAuthentication again. This way is considered more secure than uploading the key to a Dropbox in case you don’t have any other server to us.

  1. Log in to the console on the DigitalOcean website.
  2. Type sudo nano /etc/ssh/sshd_config
  3. Change PasswordAuthentication from “no” to “yes” and save the file
  4. Open a terminal on your computer and type ssh username@[hostname or IP address] or if on a Windows box use PuTTY for password login making sure authentication parameters aren’t pointing to a private key
  5. Login with a password
  6. Type sudo nano ~/.ssh/authorized_keys
  7. Paste public key text here and save the file
  8. Type sudo nano /etc/ssh/sshd_config
  9. Change PasswordAuthentication from “yes” to “no” and save the file
  10. Log out and attempt to log back in (if using PuTTY make sure you set up auth parameters to point to your private key)

Hope that this helps!
Regards,
Alex