Question

I need help figuring out how to set up simple static website using Apache

I am a complete newbie in terms of servers and unix systems. I have bought a domain, made a droplet and followed these 2 tutorials: https://www.digitalocean.com/community/tutorials/initial-server-setup-with-ubuntu-16-04 https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-16-04 I have also configured nameservers more than 24 hours ago & set up A records for both “domain” and “www.domain”.

All possible tools say that my domain belongs to my droplet. However, the demo page is accessible only by droplet’s IP address. I have tried seemingly everything.

domain.conf

<VirtualHost *:80>
	ServerAdmin mkeinviii@gmail.com
	ServerName domain.com
	ServerAlias www.domain.com
	DocumentRoot /var/www/domain.com/public_html
	ErrorLog ${APACHE_LOG_DIR}/error.log
	CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

apache2.conf

ServerRoot "/etc/apache2"
ServerName domain.com
Mutex file:${APACHE_LOCK_DIR} default
PidFile ${APACHE_PID_FILE}
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 5
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}
HostnameLookups Off
ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel warn
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf
Include ports.conf
<Directory />
	Options FollowSymLinks
	AllowOverride None
	Require all denied
</Directory>
<Directory /usr/share>
	AllowOverride None
	Require all granted
</Directory>
<Directory /var/www/>
	Options Indexes FollowSymLinks
	AllowOverride None
	Require all granted
</Directory>
AccessFileName .htaccess
<FilesMatch "^\.ht">
	Require all denied
</FilesMatch>
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent
IncludeOptional conf-enabled/*.conf
IncludeOptional sites-enabled/*.conf

Subscribe
Share

I cannot answer because it gets rejected as spam. So i’ll update here. It works, now! DNS took longer to update than expected, probably.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

This question was answered by @MKeiN2:

I cannot answer because it gets rejected as spam. So i’ll update here. It works, now! DNS took longer to update than expected, probably.

View the original comment