Installing PHP-FPM with Apache2 on Ubuntu 12.10

I am trying to setup PHP-FPM on my Ubuntu 12.10 server, but I just cannot seem to get the scripts to execute. I am following instructions as per this tutorial.

I have placed this in /etc/apache2/sites-available/default and restarted Apache via sudo service apache2 restart to no avail.

<IfModule mod_fastcgi.c> AddHandler php5-fcgi .php Action php5-fcgi /php5-fcgi Alias /php5-fcgi /usr/lib/cgi-bin/php5-fcgi FastCgiExternalServer /usr/lib/cgi-bin/php5-fcgi -socket /var/run/php5-fpm.sock -pass-header Authorization </IfModule>

As I’ve read, PHP-FPM is more commonly used with NGINX, but I would love any help in getting this up and running on my LAMP setup!


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

ok, that means your PHP is not functioning… <br> <br>do you have this line in your site server config: fastcgi_pass unix:/var/run/php5-fpm.sock; <br> <br>you need to be sure the php-fpm is running. you can run this command to verify that: <br> <br>/etc/init.d/php5-fpm reload

OK <br> <br>I realised that the config in the tutorial was using the wrong socket in the Apache config, so I’ve fixed that, but now the PHP code is simply being displayed as text (and not executing as PHP?)

Hi, I’ve tried following this, but I keep getting the error: <br> <br>(111)Connection refused: FastCGI: failed to connect to server “/usr/lib/cgi-bin/php5-fcgi”: connect() failed <br> <br>Even though my apache2.conf (also tried in a vhost or default conf in sites-available) contains <br> <br>Alias /php5.fastcgi /var/www/fastcgi/php5.fastcgi <br>FastCGIExternalServer /var/www/fastcgi/php5.fastcgi -socket /var/run/php-fpm.sock <br> <br>Not quite sure what I’m doing wrong at this point? I’ve also seen different discussion about running socket vs over IP ( between Apache 2.4 and 2.2?

An autofill changed the title of this post and I can’t seem to edit it. The original title was: ‘Installing PHP-FPM with Apache2 on Ubuntu 12.10’