Question

LEMP stack restarting error

I followed the LEMP stack tutorial at https://www.digitalocean.com/community/articles/how-to-install-linux-nginx-mysql-php-lemp-stack-on-ubuntu-12-04 and after configuring nginx (step6) when I restart nginx it says: <pre>nginx: [emerg] “fastcgi_pass” directive is duplicate in /etc/nginx/sites-enabled/default:69 nginx: configuration file /etc/nginx/nginx.conf test failed</pre>


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Comment one directive. You have both uncommented. just do this as mine.

pass PHP scripts to FastCGI server

    #
    location ~ \.php$ {
            include snippets/fastcgi-php.conf;
    #
    #       # With php-fpm (or other unix sockets):
            fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;
    #       # With php-cgi (or other tcp sockets):
    #       fastcgi_pass 127.0.0.1:9000;
    #}

    # deny access to .htaccess files, if Apache's document root
    # concurs with nginx's one
    #
    location ~ /\.ht {
            deny all;
    }

}

Open your /etc/nginx/sites-enabled/default and find fastcgi_pass you have written two times. remove one <br>Example <br>location ~ .php$ { <br> fastcgi_split_path_info ^(.+.php)(/.+)$; <br> # NOTE: You should have “cgi.fix_pathinfo = 0;” in php.ini <br> <br> # # With php5-cgi alone: <br> fastcgi_pass 127.0.0.1:9000; <br> # # With php5-fpm: <br> fastcgi_pass unix:/var/run/php5-fpm.sock; <br> fastcgi_index index.php; <br> include fastcgi_params; <br> <br> }

As it says, you got the fastcgi_pass variable two times in your configs. Remove one of em.