Manage DigitalOcean MySQL Database with MySQL Workbench - Reverse Engineer

Posted January 15, 2021 1.2k views
MySQLDatabasesDigitalOcean Managed MySQL Database


I am using Digital Ocean MySQL database service with MySQL workbench to manage it (Version 8.0.22 build 107600 CE 64 bit).

I have succesfully connected to the database with MySQL workbench and can see my schema and tables. However i am not enable to reverse engineer my scheme into an ER model. When it imports the MySQL table objects it says:

  • ERROR: (0, 16) “Test” is not valid at this position for this server version, expecting an identifier
  • ERROR: (3, 13) “User” is not valid at this position for this server version, expecting an identifie

Steps to reproduce

  1. Connect to digital ocean database with MySQL Workbench.
  2. Create a schema called “Test”.
  3. Create a table called “User”.
  4. Add a column called “id” and set it as primary key.
  5. Apply the table
  6. Go to the tab “Database -> Reverse Engineer”
  7. Choose the scheme you created and complete the steps until you get the option to select what table objects you want to import
  8. Import all the table object
  9. Now you will get the error: “” is not valid at this position for this server version.

Does anyone have this issue and knows a solution for it?

Thanks in advance

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
4 answers

Asked DigitalOcean support and they managed to find a solution.

Remove ANSI_QUOTES from Global SQL Mode for the managed database server and it worked for me.

I have the same problem. Did you manage to fix it?

I found a “patch solution”. I export only the structure of the schema in question from the digitalocean database and, in a local environment on my computer, I generate the model from it. Not the optimal way, but it worked for me. I hope this helps you with something.

I managed to solve this problem by changing the setup connection configuration to Database from MySQL Workbench.
Please change for below:-
MySQL Workbench > Advance > SQL_MODE = TRADITIONAL

After setting this parameter, then, you can reverse engineer and complete all the subsequent steps using the step-by-step wizard from the reverse engineer menu for your desire database.

Hope this solution solve your problem too.