Question

No data received / This webpage is not available

I’ve followed all of these guides in every detail:

I’m using Ubuntu 14.04 x32

Screenshot of DNS settings in DO’s control panel LOG: http://i62.tinypic.com/14uj6mw.jpg Config File The above file is also linked to from sites-enabled and the original default file link in sites-enabled has been removed. NGINX user nginx.conf

I’ve uncommented the line: server_names_hash_bucket_size 64; In nginx.conf as the tutorial said.

I’ve not installed any firewalls and I’ve allowed port 80 in UFW that ships with ubuntu. I’ve done whois and ping on my domain name and it’s pointing to DO’s 3 nameservers and my droplets IP.

I’ve asked DO’s support for help and they said I’ve done everything correctly and they don’t know what is causing the problem and adviced me to ask the community instead for help.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I fixed it by destroying the server and doing all the setup from scratch again.