unilynx
By:
unilynx

Online resizing not possible?

July 13, 2017 744 views
Block Storage

The 'resize' action for volumes is grayed out and now says

"attached droplet must be powered off"

I used to be able to resize online, what could be going on?

1 comment
1 Answer
jtittle MOD July 13, 2017
Accepted Answer

@unilynx

When it comes to the disk, ideally, you don't want to potentially write data to the disk during a resize, which is why powering down is required -- the same is true for when you resize the primary disk.

This is more so a safety precaution to ensure that you don't lose data during the resize. When you're handling the disk, it's best to do so with caution. Even though resizing is recognized as safe, I always recommend taking a snapshot (which is the same advice I give all customers).

  • @jtittle no offense, but if writing to a disk being resized online is suddenly dangerous, then either you've found a bug that noone in the LVM, Linux and iSCSI communities know about, or there are some scary issues in Digital Ocean's block storage implementation. Online resizing has been supported for more than a decade in Linux, and usually you wouldn't resize a filesystem until the resize is complete anyway - nothing will be writing to the 'new' space until the resize is done.

    This worked fine a few weeks ago, so I was actually expecting answers along the line of "We're doing maintenance, the feature will be back soon" or "it's a platform issue that will go away after reboot/migration/first resize of the volume"

    Not really a "online resizing is extremely dangerous, we've blocked it for safety reasons, and all those other providers are really just gambling with your data" :-)

    • @unilynx

      None taken :-).

      I took the question to our Cloud Ops Team to get a more definitive answer and it looks like there is a current issue that is being worked on. Until the issue is resolved, resizes to Block Storage Volumes will function like resizes to the primary disk (i.e. a shutdown will be required).

      As of right now, the issue is being worked on and was recently updated, though I don't have an ETA as to when live resizing will be re-enabled just yet.

Have another answer? Share your knowledge.