Question

permalinks (arch + nginx + wordpress)

Hi guys, I installed on my machine arch + nginx and I’m trying to run a wordpress site . It is installed in /srv/http/wordpress/ . I’m getting crazy with the nginx configuration. In order to work properly with wordpress and permalinks , you should change some config on nginX , so i did. I’ve created one specific wordpress.conf on sites-available/enabled and I’m including them on ngin.conf. Well the closest i got is the following: http://82.196.9.187/wordpress/

Now, the permlinks are working , but i have no freaking idea why every other link (css,js) are pointing to the index.php also)

Someone to help me out a bit? any lights? I tried every configuration possible found on the net…

Cheers,


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Presuming the rest of your setup is correct then <a href=“http://wordpress.org/plugins/nginx-helper/”>nginx helper</a> will make nginx play nicely with permalinks. Just turn off its nginx-cache-purge stuff if you aren’t using it.

How did you do it? It sounds like you just redirected everything to the index.php instead of only non-existing directories and files. When I googled, I found http://nginxlibrary.com/wordpress-permalinks/ which should do the job.