Phalcon extension info not showing in phpinfo()

May 25, 2014 4.3k views
Hi all, Brand new to DO and getting my first server up and running - little by little... Have worked through the walk-through here ( for getting Phalcon set up. Looks OK, no errors. I've added to the php.ini file and restarted Apache, but I'm not seeing a phalcon section in the output from phpinfo(). Can't think what I've missed. I'm guessing the library has been installed in a non-standard location? Any suggestions appreciated. Mark
8 Answers

I have also encounter the same problem but unable to resolve it using these steps.

Just checked the php.ini file and the extension_dir is commented out... doh ..question is where would that be on my Ubuntu server?
phpinfo() tellls me the extensions are at /usr/lib/php5/20121212, which I've added to the ini. Still can't see phalcon.
Hmm.. looks like the path to the extensions directory is OK and the file is in there. Version mismatch somewhere?
Is there a specific place in the ini file I need to put the entry. It's currently the last thing in the file.
SOLVED - the way extensions are referenced seems to have changed or be different on Ubuntu. I'n guessing the former. Found this on the Phalcon forum:
Glad you figured it out Mark! Thanks for following up and leaving your solution for everyone else.

I have the same problem. I use LEMP on Ubuntu . I have tried all this steps but it doesn't help.
Please any suggestions

Have another answer? Share your knowledge.