Problem setting up chrome in a droplet

Hi, i was trying to run a Flask API in a droplet using the same script and Dockerfile that worked for me in other sites but i keep getting an error while i try to install chrome. I tried a couple of fixes i’ve seen in this community but nothing worked so far, any help would be appreaciated it’s my first time in digital ocean

This is the error while i build the docker in the VM:

   8 |
   9 | >>> RUN apt-get update && apt-get install -y wget unzip && \
  10 | >>>     wget && \
  11 | >>>     apt-get install -y ./google-chrome-stable_current_amd64.deb && \
  12 | >>>     rm google-chrome-stable_current_amd64.deb && \
  13 | >>>     apt-get clean
  14 |
ERROR: failed to solve: process "/bin/sh -c apt-get update && apt-get install -y wget unzip &&     wget &&     apt-get install -y ./google-chrome-stable_current_amd64.deb &&     rm google-chrome-stable_current_amd64.deb &&     apt-get clean" did not complete successfully: exit code: 100

OS: Debian 10


FROM python:3.10


COPY . /app

RUN pip install --trusted-host -r requirements.txt

RUN apt-get update && apt-get install -y wget unzip && \
    wget && \
    apt-get install -y ./google-chrome-stable_current_amd64.deb && \
    rm google-chrome-stable_current_amd64.deb && \
    apt-get clean

CMD ["python", ""]

requirements.txt :


And lastly my selenium setup:

chrome_options = Options()

I don’t actually need the OS to be Debian so if anyone tried or have a fix in other OS i’m willing to try.

Thanks again!

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Bobby Iliev
Site Moderator
Site Moderator badge
June 7, 2024

Hi there!

The Dockerfile actually looks correct, I think that the issue here might be that the Chrome repository doesn’t provide arm64 packages.

Is the Droplet that you are using ARM-based by any chance? If so, what you could do is to spin up another Droplet with a regular or Intl CPU instead.

Let me know how this goes!

- Bobby

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel