Question

Receiving "SignatureDoesNotMatch" errors when using Spaces with Transmit 5.0

I just set up a Space and am attempting to use Transmit 5.0 to access it.

I’ve used the information in my control panel to set up my Spaces login as an S3 instance in Transmit. And, it successfully logs in.

However, when I try to access the root bucket, I get a “SignatureDoesNotMatch” error. My Space is set to read/write and should be publicly viewable.

Thoughts on what’s up?

Subscribe
Share

No, still same error. The key/secret works fine with s3cmd though, so it must be a problem Transmit 5. Need to file a support ticket with them.

I am also having this issue. Did you get it resolved? I have regenerated keys and tried that, but am still getting this error.

Hi @jeremyfuksa would you mind sharing where/hoe you generate proper the equivalent of the key/secret in Digital Ocean? I am trying as well using Transmit and s3cmd but with no luck.

Thanks!


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I’m no longer seeing this issue in the latest release. It seems to have been fixed.

cc @johngannon

Hi everyone - I’m the product manager for Spaces.

Transmit 5 is not supported at the moment in Spaces (known issues).

However, we do have a tutorial for using Transmit 4 with Spaces here: https://www.digitalocean.com/community/tutorials/how-to-manage-digitalocean-spaces-with-transmit-4

Hope this helps and please continue to share your feedback about the product.

@jeremyfuksa, thank you for responding. Yes, I did this that. But it only provide the access_key, what about the secret_key (the second part, required to access AWS S3 as well). Am I missing something in the UI?

If you go into the API settings of your control panel, you’ll see a section for Spaces access keys. You can do it there.

This comment has been deleted