Reposting: im getting "503 Service Temporarily Unavailable nginx" when i do "www." on my website

  • Posted on July 20, 2020
  • DNS
  • XunneAsked by Xunne

im getting “503 Service Temporarily Unavailable nginx” when i do “www.” on my website it is working if i just entered my domain without www. it is working I am using easyengine with wordpress and cloudflare for ssl/dns. I tried changing cname on DO and Cloudfkare same issue also tried using A with ip still the same issue please help

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

hi @bobbyiliev sorry i haven been able to respond to your post i actually found a sulution from easyengine her is the page: thank you again for responding

Hi! I was having the same issue and i found this post through google. I have found a way to make it work but it’s not the correct one. I will give my way and hope someone can help us both fix it haha.

I am running a docker compose file in my raspberry pi to host my domain’s website + let’s encrypt certificates. The docker compose file has the budry/jwilder-nginx-proxy-arm, duch/letsencrypt-nginx-proxy-companion:stable and nginx images (the full compose file is from a spanish youtuber hosted in ).

What I did was run the compose, copy the /etc/nginx/conf.d/default.conf from the nginx_proxy container to the pi with the command docker cp containerid:/etc/nginx/conf.d/default.conf .

edit it with vim or nano and add the next to my in both server_name lines in the file and copy the file back to the container. Then enter into the container with the command docker exec -it containerid /bin/bash

and once inside the container I run the command nginx -s reload

Then i checked the and worked perfectly. The only problem now is that this change isn’t persistent and when I run the docker compose file again, the /etc/nginx/conf.d/default.conf gets rewritten and the isn’t next to the in the server_name line. Do you think how can i make docker nginx_proxy file not rewrite it? It might be the solution for the both of us hopefully.

Thanks and hope it works with you as well!

This comment has been deleted

    Try DigitalOcean for free

    Click below to sign up and get $200 of credit to try our products over 60 days!

    Sign up

    Featured on Community

    Get our biweekly newsletter

    Sign up for Infrastructure as a Newsletter.

    Hollie's Hub for Good

    Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

    Become a contributor

    Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

    Welcome to the developer cloud

    DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

    Learn more
    DigitalOcean Cloud Control Panel