Question

Server blocks is not reached in some browsers

0

I have in the last week started with digitalocean droplet system and have set up my first droplet with LEMP stack while following Initial setup and Quickstart guide. I did remove the tag for the last configuration with the cloud firewall because I did not get it working. I then followed how to set up server blocks which worked pretty much fine with the exception that it doesn’t work on all web browsers.

On chrome it redirects to the default site but on firefox it goes through to the server block. I have tried to look this up on similar questions, fixing it with configuring the firewall, with no success. In /etc/nginx/sites-available there exists four files: mydomain.com, mydomain2.com, default and digitalocean (is digitalocean supposed to be here?). I checked each file to make sure the name server is unique and only one have default server.

I also noticed that when the ip address is in the search field the site says the connection is not secure but when domain.com is searched on chrome it is secured. Alternatively domain.com is not secured on firefox but it does reach the server block.

Any help would make my day!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @ulvar,

No need to have DigitalOcean configuration there. Additionally, can you please provide us with one of the configuration files so that we can see if anything is missed or needs to be added to it?

Additionally, what I’ll recommend is checking the Nginx’s Access and Error logs for further information as to why it’s not loading the website.

Regards, KFSys