SFTP Authentication Error

I can’t seem to SFTP into my droplet. I have no issues getting in via the console (user and password, not ssh)

I’ve tried:

Server: I’ve tried it using both the raw IP address and the domain name with A record pointing to the IP. Neither works.

username: root

Password: I’ve created 2 new passwords in the console. All work (with username root) via the console. Neither worked in SFTP.

Port: Using port 22. Port 22 is allowed, when I look at ufw in the console.

Firewall: I’ve also tried completely disabling the firewall. That failed. When I tried enabling the firewall again, with tcp/22 There was no change.

I’ve tried powering down and the restarting the whole droplet. Also, droplet is original, not from a backup or snapshot.

Using Cyberduck for SFTP.

The error message I get is: "Login failed. Exhausted available authentication methods. Please contact your web hosting service provider for assistance. Please contact your web hosting service provider for assistance."

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

A Mac. Thank you so much!

Hi Bobby, Yeah, I changed to Filezilla. I think I’ve isolated the issue, I just don’t know how to fix it.

My keys are publicly accessible and so if I try to SSH into my droplet, I get an error message saying that my keys will be ignored because other people have access to them (even though I’m the only user).

I’m not sure where my keys are in the droplet (since I don’t have access to SFTP, it’s hard to find it) and even if I did, I don’t know how to move the keys to a private .ssh folder that no one else has access to.

Any ideas?

My mistake. I did it correctly in the file. I mistakenly added it here. It still isn’t working properly.