SFTP Dosen't work from filezilla, help pls!!

February 22, 2016 8.6k views
Ubuntu DigitalOcean Deployment

Hello,

I can access with success to sftp via terminal from my mac, But I can’t connect from filezilla or cyberduck, I follow this tutorial.

Also I tried with those access :

Host: sftp://Your_IP
User: root (or your username)
Password: Your password

Always I get the same error :

  Error: Timeout expired
  Error: Unable to connect to server

I need to make a configuration for my droplet ?

Any help pls

8 comments
1 Answer

This is because you are probably using an SSH key to log in from your terminal. In the tutorial, it is highlited that you are supposed to add a key file to either filezilla or cyberduck. Please repeat the steps under the title “SFTP via SSH2 Key-based Authentication” within the tutorial you used. The first image under that section explains it all. After you are done you will not need a password

by Pablo Carranza
This article will teach you how to use Filezilla to transfer and manage files securely on your VPS.
Have another answer? Share your knowledge.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!