Sftp slow upload

Hi, I’m using sftp and have this trouble. Upload rate won’t get higher than 150 kbps. There’s no firewall, any speed limiting settings or whatever on my side. It’s ubuntu x32 out of the box. Definitely there’s an issue with droplet or smth. Tried different OS: debian,ubuntu,32 and 64. Problem always stays. Maybe a little tip where to look? Please.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Ok solved myself. For future help. Run this command: ifconfig eth0 txqueuelen 1000. Rate increased from 150 to 800 kbps. Much funnier

I know this for sure because also I’m using at the same time another company’s vps. And before I’ve used for several years shared hosting. So I know what right upload rate is. Now I’ve run the test you asked about it’s results are download rate:48 Mbps , upload: 24 Mbps. When you develop an app in IDE it’s quite obvious that upload that earlier took an instant now takes quite time. I’m drearly gaping at UPLOAD PROGRESS BAR. I’ve never known my ide had it ). Please help to solve it man…

How do you know that it’s not your own broadband connection? Have you run a <a href=“”>SpeedTest</a>? Are you getting an upload rate significantly higher than 150 kbps?