SPF record is not matching rDNS for multiple domains on a single droplet

I have a droplet with LAMP stack installed. Using Plesk, I have managed to host 10 domains successfully.

Let’s say my host name is set as “myHost.local” so DigitalOcean provides me a rDNS record for that (which I don’t have access). Then I have 10 domains hosted as,, …, domain all with their own DNS, SSL, email and everything set properly and functioning smoothly.

Now, the problem is that when I want to set an SPF record for my emails, it will technically look like this:

“v=spf1 +a +mx +a:myHost.local -all”

  • Since there is no A record for that host name in every domain’s DNS records, all the emails that I send end up in recipient’s spam folder or get rejected.

  • If I change the a: identifier to my domain name, then there will be a rDNS mismatch and spamming again. I even tried to set in in include: identifier and got the same result.

  • If I change the host name to match my domain name, then I can fix it for only one of the domains and the problem remains for the rest.

Can anyone help me to set this up please? I feel very frustrated. :( Thanks in advance!

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Yes! Both positive and that is why I don’t know what would be the issue now.

Hello, @lniab

Looking at the screenshot it’s says that the reverse DNS is not a valid hostname. Could you please check on this one and make sure that the droplet has a real domain/subdomain set for a hostname. - is pointed to your droplet.

Regards, Alex

Hello, @lniab

Have you tried to set the SPF record using the IPv4 address of your droplet instead of using the droplet’s hostname? I believe this should work just fine. You can try this using the following syntax:

"v=spf1 +a +mx +ip4: -all"

Let me know how it goes.

Regards, Alex