Question

SSL Handshake Failed Error

I just set up SSL on my droplet today, but when I tried to access the SSL version of my site, I was greeted with a “SSL Connection Error”. I access the IP address of my site via SSL and received the error message below. But when I accessed the mapped domain of my site, via SSL, I received a 525 Server Error; “SSL handshake failed” Any advice?

Exact error message: Unable to make a secure connection to the server. This may be a problem with the server, or it may be requiring a client authentication certificate that you don’t have. Error code: ERR_SSL_PROTOCOL_ERROR

Mapped Domain Error message via CloudFlare: http://postimg.org/image/nvwzzuyb5/

Tutorial I followed: https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-with-a-free-signed-ssl-certificate-on-a-vps

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I finally fixed it after, what felt like a lifetime of editing virtual host files.

DocumentRoot /Directory/of/Website/

  <Directory />
       Options FollowSymLinks
       AllowOverride All
   </Directory>
   <Directory /Directory/of/Website/>
       Options Indexes FollowSymLinks MultiViews
       AllowOverride All
       Order allow,deny
       allow from all
   </Directory>

Change “none” in the “AllowOverride” lines to “all” in the Virtual Host config for port 443. Or whatever port you have SSL running on.

Well, I disabled Bitdefender’s scan SSL function and everything seems to work find now…