SSL Handshake Failed Error

Posted November 10, 2014 14.5k views

I just set up SSL on my droplet today, but when I tried to access the SSL version of my site, I was greeted with a “SSL Connection Error”. I access the IP address of my site via SSL and received the error message below. But when I accessed the mapped domain of my site, via SSL, I received a 525 Server Error; “SSL handshake failed” Any advice?

Exact error message:
Unable to make a secure connection to the server. This may be a problem with the server, or it may be requiring a client authentication certificate that you don’t have.

Mapped Domain Error message via CloudFlare:

Tutorial I followed:


These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers

Well, I disabled Bitdefender’s scan SSL function and everything seems to work find now…

I finally fixed it after, what felt like a lifetime of editing virtual host files.

DocumentRoot /Directory/of/Website/

   <Directory />
        Options FollowSymLinks
        AllowOverride All
    <Directory /Directory/of/Website/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Order allow,deny
        allow from all

Change “none” in the “AllowOverride” lines to “all” in the Virtual Host config for port 443. Or whatever port you have SSL running on.