Hello,

I can’t do telnet to any server or to my localhost.

->>telnet localhost 2181
Trying 127.0.0.1…
telnet: Unable to connect to remote host: Connection refused

How can i disable the firewall ?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Telnet is not enabled by default, neither is firewall.

If this is new server, you need to access it using SSH,
How To Connect To Your Droplet with SSH will show you how to do so.

Once you get into Droplet, you can find out how to install telnet, but:
WARNING: Telnet is insecure protocol and is not recommended to be used! All data you send to server using telnet (including passwords) are sent in plain-text form, unencrypted. SSH is encrypted and much more secure than telnet.

If you already logged in, installed telnet but you followed Initial set up tutorial (incl. Step 7), then you have enabled UFW firewall. To check is it enabled run:

  • sudo ufw status

In case it’s enabled just allow:

  • sudo ufw allow 23/tcp

But if you didn’t set up telnet manually, you need to do so (not recommended).

by Mitchell Anicas
When you start a new server, there are a few steps that you should take every time to add some basic security and give you a solid foundation. In this guide, we'll walk you through the basic steps necessary to hit the ground running with Ubuntu 16.04.
Submit an Answer