unable to connect to the database using ssh

December 3, 2017 747 views
MySQL

Hi Guys, I am trying to ssh to my droplet's database but nothing is working

Here is what I get from gitbash, However I can normally connect to the droplet using
ssh user@ipaddress
But I want to go inside the database.

ssh -f forge@67.207.89.63 -L 12000:[::1]:12000 -N -v -v -v -v
OpenSSH_7.6p1, OpenSSL 1.0.2m  2 Nov 2017
debug1: Reading configuration data /etc/ssh/ssh_config
debug2: resolving "67.207.89.63" port 22
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to 67.207.89.63 [67.207.89.63] port 22.
debug1: Connection established.
debug1: identity file /c/Users/USERNAME/.ssh/id_rsa type 0
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/USERNAME/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/USERNAME/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/USERNAME/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/USERNAME/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/USERNAME/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/USERNAME/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/USERNAME/.ssh/id_ed25519-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_7.6
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.2p2 Ubuntu-4ubuntu2.2
debug1: match: OpenSSH_7.2p2 Ubuntu-4ubuntu2.2 pat OpenSSH* compat 0x04000000
debug2: fd 3 setting O_NONBLOCK
debug1: Authenticating to 67.207.89.63:22 as 'forge'
debug3: hostkeys_foreach: reading file "/c/Users/USERNAME/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /c/Users/USERNAME/.ssh/known_hosts:14
debug3: load_hostkeys: loaded 1 keys from 67.207.89.63
debug3: order_hostkeyalgs: prefer hostkeyalgs: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521
debug3: send packet: type 20
debug1: SSH2_MSG_KEXINIT sent
debug3: receive packet: type 20
debug1: SSH2_MSG_KEXINIT received
debug2: local client KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha256,diffie-hellman-group14-sha1,ext-info-c
debug2: host key algorithms: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-ed25519-cert-v01@openssh.com,ssh-rsa-cert-v01@openssh.com,ssh-ed25519,rsa-sha2-512,rsa-sha2-256,ssh-rsa
debug2: ciphers ctos: aes128-ctr,aes192-ctr,aes256-ctr,aes128-cbc,3des-cbc,aes256-cbc,aes192-cbc
debug2: ciphers stoc: aes128-ctr,aes192-ctr,aes256-ctr,aes128-cbc,3des-cbc,aes256-cbc,aes192-cbc
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com,zlib
debug2: compression stoc: none,zlib@openssh.com,zlib
debug2: languages ctos:
debug2: languages stoc:
debug2: first_kex_follows 0
debug2: reserved 0
debug2: peer server KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1
debug2: host key algorithms: ssh-rsa,rsa-sha2-512,rsa-sha2-256,ecdsa-sha2-nistp256,ssh-ed25519
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com
debug2: compression stoc: none,zlib@openssh.com
debug2: languages ctos:
debug2: languages stoc:
debug2: first_kex_follows 0
debug2: reserved 0
debug1: kex: algorithm: curve25519-sha256@libssh.org
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: aes128-ctr MAC: umac-64-etm@openssh.com compression: none
debug1: kex: client->server cipher: aes128-ctr MAC: umac-64-etm@openssh.com compression: none
debug3: send packet: type 30
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug3: receive packet: type 31
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:gBeCNrIoEDQMK+QzFcmhFZmXtTRyqxRxGZ2OhDYfHeM
debug3: hostkeys_foreach: reading file "/c/Users/USERNAME/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /c/Users/USERNAME/.ssh/known_hosts:14
debug3: load_hostkeys: loaded 1 keys from 67.207.89.63
debug1: Host '67.207.89.63' is known and matches the ECDSA host key.
debug1: Found key in /c/Users/USERNAME/.ssh/known_hosts:14
debug3: send packet: type 21
debug2: set_newkeys: mode 1
debug1: rekey after 4294967296 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug3: receive packet: type 21
debug1: SSH2_MSG_NEWKEYS received
debug2: set_newkeys: mode 0
debug1: rekey after 4294967296 blocks
debug2: key: /c/Users/USERNAME/.ssh/id_rsa (0x600061410)
debug2: key: /c/Users/USERNAME/.ssh/id_dsa (0x0)
debug2: key: /c/Users/USERNAME/.ssh/id_ecdsa (0x0)
debug2: key: /c/Users/USERNAME/.ssh/id_ed25519 (0x0)
debug3: send packet: type 5
debug3: receive packet: type 7
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<rsa-sha2-256,rsa-sha2-512>
debug3: receive packet: type 6
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug3: send packet: type 50
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey
debug3: start over, passed a different list publickey
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering public key: RSA SHA256:ldYVuHWw7DVPEbX0up91OHyYpdM44qyhIpOWuCk/mMc /c/Users/USERNAME/.ssh/id_rsa
debug3: send_pubkey_test
debug3: send packet: type 50
debug2: we sent a publickey packet, wait for reply
debug3: receive packet: type 60
debug1: Server accepts key: pkalg rsa-sha2-512 blen 279
debug2: input_userauth_pk_ok: fp SHA256:ldYVuHWw7DVPEbX0up91OHyYpdM44qyhIpOWuCk/mMc
debug3: sign_and_send_pubkey: RSA SHA256:ldYVuHWw7DVPEbX0up91OHyYpdM44qyhIpOWuCk/mMc
debug3: send packet: type 50
debug3: receive packet: type 52
debug1: Authentication succeeded (publickey).
Authenticated to 67.207.89.63 ([67.207.89.63]:22).
debug1: Local connections to LOCALHOST:12000 forwarded to remote address ::1:12000
debug3: channel_setup_fwd_listener_tcpip: type 2 wildcard 0 addr NULL
debug3: sock_set_v6only: set socket 4 IPV6_V6ONLY
debug1: Local forwarding listening on ::1 port 12000.
bind: Address already in use
debug1: Local forwarding listening on 127.0.0.1 port 12000.
bind: Address already in use
channel_setup_fwd_listener_tcpip: cannot listen to port: 12000
Could not request local forwarding.
debug2: fd 3 setting TCP_NODELAY
debug3: ssh_packet_set_tos: set IP_TOS 0x10
debug1: Requesting no-more-sessions@openssh.com
debug3: send packet: type 80
debug1: forking to background
debug1: Entering interactive session.
debug1: pledge: network
debug3: receive packet: type 80
debug1: client_input_global_request: rtype hostkeys-00@openssh.com want_reply 0

Success@ChaudhryWaqas MINGW64 ~
$ debug3: send packet: type 1
Connection reset by 67.207.89.63 port 22
debug3: send packet: type 1
Connection reset by 67.207.89.63 port 22
Connection reset by 67.207.89.63 port 22
Connection reset by 67.207.89.63 port 22
Connection reset by 67.207.89.63 port 22
debug3: send packet: type 1
Connection reset by 67.207.89.63 port 22
Connection reset by 67.207.89.63 port 22
Connection reset by 67.207.89.63 port 22
debug3: send packet: type 1
debug3: send packet: type 1
Connection reset by 67.207.89.63 port 22
Connection reset by 67.207.89.63 port 22
debug3: send packet: type 1
debug3: send packet: type 1
debug3: send packet: type 1
Connection reset by 67.207.89.63 port 22
Connection reset by 67.207.89.63 port 22
debug3: send packet: type 1
Connection reset by 67.207.89.63 port 22
debug3: send packet: type 1
Connection reset by 67.207.89.63 port 22
debug3: send packet: type 1
debug3: send packet: type 1
debug3: send packet: type 1
Connection reset by 67.207.89.63 port 22

1 Answer

You can't directly SSH to your database because it's a different protocol. If you want to access your database from the command line and be able to execute commands from there you would need to SSH to your server normally and then:

#$ mysql -h localhost -u myname -ppassword mydb

-h specifies hostname, which in this case is localhost, which means connect to the server itself that you are currently on.

-u is the user you want to access mysql with, you can do this as the root user for mysql, or a specific username that you have created to access a specific DB.

-p is the password for that user.

"mydb" is the name of the database you want to access, or you can leave it blank to just access the mysql command line and then issue the use command to select a database:

mysql> use dbname;
Have another answer? Share your knowledge.