Question

Updates on droplet server do not show on page

Dear DO-community, I run a Grav-page on a Droplet and have run into troubles. When I make changes on the server (Ubuntu) they do not show on browser (I have tried different browsers and devices, as well as clearing cache on my main browser). I even removed all files on the server (with exception for a backup zip-file) and the page looks the same on browser. The page looks the same when I type the IP-number in browser. When I turn off the droplet, the page does not show.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @forsariks,

This does sound to me like a caching problem. Unlike other applications where it is hard to find the clear cache option and you have to look under every tab in the configuration and settings menus, in Grav the Clear Cache button is right on top of the admin dashboard screen. Just select the type of cache you want to clear (or all of it) and you are done.

Hope that helps!

Hi there,

Have you tried clearing your Grav cache after making your changes? You can do that with the following commands:

  • First access the Grav directory:
cd /path/to/your/grav/installation

Note: change the /path/to/your/grav/installation part accordingly based on where you’ve installed the project.

  • Then clear the cache with:
./bin/grav clearcache

Let me know how it goes!

Best,

Bobby