Question

Vagrant and VirtualBox gurumeditation problem

  • Posted June 23, 2014

This is related to this question: https://www.digitalocean.com/community/questions/install-vagrant-on-ubuntu-12-04

The above question did not receive any answer that was accepted, or indeed helpful. I’ve been at it for two days.

In summary, I create an Ubuntu droplet (tried both 12.04 and 14.04), I install VirtualBox and Vagrant (I’ve tried both apt-get versions and versions directly from Oracle and VagrantUp in all combinations). Then I add a box to vagrant (I’ve tried 7 different boxes, both 32 and 64 bit), and vagrant up. Once I do that, I get

<pre> The guest machine entered an invalid state while waiting for it to boot. Valid states are ‘starting, running’. The machine is in the ‘gurumeditation’ state. Please verify everything is configured properly and try again.

If the provider you’re using has a GUI that comes with it, it is often helpful to open that and watch the machine, since the GUI often has more helpful error messages than Vagrant can retrieve. For example, if you’re using VirtualBox, run vagrant up while the VirtualBox GUI is open. </pre>

From the logs, VirtualBox exits with error 4005 (whatever that means).

Any help is much appreciated.

Subscribe
Share

Second thread I’ve found about the error I’m having. Still no answer. :( Did you figure it out?

This comment has been deleted


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Still no solution, huh?

An issue since 2014 and no fix yet ? +1

I’m still searching for a solution to this problem. Tried all the different things but nothing works so far. Using Ubuntu 14.04.

I solved the problem using my latest OS version: http://enriquezrene.com/home/index.php/devops/vagrant

Hey

Since I had this problem last night, and it seems like some people haven’t found a solution for it, here’s what did it for me:

Turn off the hardware virtualisation extensions either from the console

vboxmanage modifyvm --hwvirtex off

or in the vagrantfile

config.vm.provider :virtualbox do |vb|
        vb.customize ["modifyvm", :id, "--hwvirtex", "off"]
 end

Turn off Intel VT-x virtualisation

vboxmanage modifyvm --vtxvpid off

or

config.vm.provider :virtualbox do |vb|
        vb.customize ["modifyvm", :id, "--vtxvpid", "off"]
 end

I’m also setting the memory to about half of what’s available on the Droplet. Kind of an arbitrary decision. I’m pretty new to this, but it seems like a good idea.

More info on those options here: http://www.virtualbox.org/manual/ch08.html Here’s the page that pointed me in this direction: https://www.virtualbox.org/ticket/7766

fucking brutal, +1 here as well, can’t get vagrant up

Same here.

I was trying to install flynn on a droplet. One of the the steps is to install VirtualBox and Vagrant. Now I’m starting to wonder if it’s because the app has run out of memory. There’s only 512MB memory available on the droplet. Sounds not solid enough to launch another virtual machine.

+1, same issue.

Same here, guys.