Vagrant and VirtualBox gurumeditation problem

June 23, 2014 13.9k views

This is related to this question:
https://www.digitalocean.com/community/questions/install-vagrant-on-ubuntu-12-04

The above question did not receive any answer that was accepted, or indeed helpful. I've been at it for two days.

In summary, I create an Ubuntu droplet (tried both 12.04 and 14.04), I install VirtualBox and Vagrant (I've tried both apt-get versions and versions directly from Oracle and VagrantUp in all combinations). Then I add a box to vagrant (I've tried 7 different boxes, both 32 and 64 bit), and vagrant up. Once I do that, I get

<pre>
The guest machine entered an invalid state while waiting for it
to boot. Valid states are 'starting, running'. The machine is in the
'gurumeditation' state. Please verify everything is configured
properly and try again.

If the provider you're using has a GUI that comes with it,
it is often helpful to open that and watch the machine, since the
GUI often has more helpful error messages than Vagrant can retrieve.
For example, if you're using VirtualBox, run vagrant up while the
VirtualBox GUI is open.
</pre>

From the logs, VirtualBox exits with error 4005 (whatever that means).

Any help is much appreciated.

1 comment
  • Second thread I've found about the error I'm having. Still no answer. :( Did you figure it out?

14 Answers

running virtual machine inside another virtual machine doesnt work for most of times. Especially when virtual machines differ.

Digitalocean offers KVM as hypervisor

  • That's useful information, thank you!

    However, in that case, why would DigitalOcean specifically give instructions on how to bring up Vagrant on their Ubuntu 12.04 droplets? I'm really hoping I can get this to work.

It's definitely possible to use Vagrant on a droplet. I just ran through the tutorial with a 2GB droplet with no issues.

Unfortunately, that's a very general error. Is there anything else about the VirtualBox error in the log? One thing I've read that could lead to that error is not having PAE support enabled for the VirtualBox vm. That should be the default these days, but you could give it a shot. First check if it's enabled:

VBoxManage list vms -l | grep PAE

If it isn't you can enable it with:

VBoxManage modifyvm your_vm_id --pae on

What size droplet are you on? Maybe it's running out of memory?

  • Thanks a lot for the comment! Could you specify which versions of Ubuntu (32/64), VirtualBox and Vagrant you used? Specifically, how you installed VirtualBox and Vagrant (binaries, source, apt-get or Oracle / VagrantUp)?

  • On the quick test I did earlier, I was on a 64bit Ubuntu 14.04 host system. I used VirtualBox from the Ubuntu repositories w/ Vagrant 1.3.5 using the Debian package from downloaded from VagrantUp. I was able to spin up multiple precise32 boxes.

  • I'm having the same issue. I've tried several sizes droplets on Ubuntu 14.04 and 14.10 on ams and nyc - no success.
    What I'm doing:
    apt-get install virtualbox
    apt-get install vagrant
    vagrant box add precise32 http://files.vagrantup.com/precise32.box
    vagrant init precise32
    vagrant up
    Here is the result:
    Bringing machine 'default' up with 'virtualbox' provider...
    [default] Importing base box 'precise32'...
    [default] Matching MAC address for NAT networking...
    [default] Setting the name of the VM...
    [default] Clearing any previously set forwarded ports...
    [default] Clearing any previously set network interfaces...
    [default] Preparing network interfaces based on configuration...
    [default] Forwarding ports...
    [default] -- 22 => 2222 (adapter 1)
    [default] Booting VM...
    [default] Waiting for machine to boot. This may take a few minutes...
    The guest machine entered an invalid state while waiting for it
    to boot. Valid states are 'starting, running'. The machine is in the
    'gurumeditation' state. Please verify everything is configured
    properly and try again.

    If the provider you're using has a GUI that comes with it,
    it is often helpful to open that and watch the machine, since the
    GUI often has more helpful error messages than Vagrant can retrieve.
    For example, if you're using VirtualBox, run vagrant up while the
    VirtualBox GUI is open.

    The final result is always the same - no matter which size and/or location I choose for droplet.

  • It looks like the issue has nothing to do with Ubuntu - I've tried to do in on CentOS 6.5 and end up with the exactly the same message in the VBox.log

    00:00:00.374704 emR3Debug: rc=VERRVMXUNABLETOSTARTVM
    00:00:01.142384 NAT: old socket rcv size: 128KB
    00:00:01.142427 NAT: old socket snd size: 128KB
    00:00:01.375638 Changing the VM state from 'RUNNING' to 'GURU
    MEDITATION'.

    So it looks like a general DO issue.

  • @asb sounds like something I'm looking for. Can you point me to the tutorial for spinning up a droplet with an existing vagrantfile project? I downloaded a project from github but would like to spin it up as a droplet. thanks!

Just wanted to +1 this issue. Getting the same gurumeditation state no matter what I do :-/

Same here.

I was trying to install flynn on a droplet. One of the the steps is to install VirtualBox and Vagrant.
Now I'm starting to wonder if it's because the app has run out of memory. There's only 512MB memory available on the droplet. Sounds not solid enough to launch another virtual machine.

fucking brutal, +1 here as well, can't get vagrant up

Hey

Since I had this problem last night, and it seems like some people haven't found a solution for it, here's what did it for me:

Turn off the hardware virtualisation extensions either from the console

vboxmanage modifyvm --hwvirtex off

or in the vagrantfile

config.vm.provider :virtualbox do |vb|
        vb.customize ["modifyvm", :id, "--hwvirtex", "off"]
 end

Turn off Intel VT-x virtualisation

vboxmanage modifyvm --vtxvpid off

or

config.vm.provider :virtualbox do |vb|
        vb.customize ["modifyvm", :id, "--vtxvpid", "off"]
 end

I'm also setting the memory to about half of what's available on the Droplet. Kind of an arbitrary decision. I'm pretty new to this, but it seems like a good idea.

More info on those options here: http://www.virtualbox.org/manual/ch08.html
Here's the page that pointed me in this direction: https://www.virtualbox.org/ticket/7766

  • Didn't work for me

  • Ok together with the PAE configuration I was able to get past the GURU MEDITATION. These are the settings I've used:

    vb.customize ['modifyvm', :id, '--pae', 'on']
    vb.customize ['modifyvm', :id, '--hwvirtex', 'off']
    vb.customize ['modifyvm', :id, '--vtxvpid', 'off']
    

    However, now I'm stuck at SSH'ing after the vagrant up command:

    ==> default: Waiting for machine to boot. This may take a few minutes...
        default: SSH address: 127.0.0.1:2222
        default: SSH username: vagrant
        default: SSH auth method: private key
        default: Warning: Connection timeout. Retrying...
        default: Warning: Connection timeout. Retrying...
        default: Warning: Connection timeout. Retrying...
        default: Warning: Connection timeout. Retrying...
        default: Warning: Connection timeout. Retrying...
        default: Warning: Connection timeout. Retrying...
    

    Any ideas? Could you share your network/ssg config?

  • These mods to the vagrantfile got me up and running as well . . . with just a few connection timeouts . . . Thanks!

I'm still searching for a solution to this problem. Tried all the different things but nothing works so far. Using Ubuntu 14.04.

An issue since 2014 and no fix yet ?
+1

Have another answer? Share your knowledge.