What do I need to learn to understand SSH setup on OS X Catalina?

Is there any manual configurations I need to add to Catalina? I can not ssh to my droplets after upgrade to Catalina, i tried using ssh -i and tried adding a ~/.ssh/config but none of that is getting me to ssh like I used to. The best I achieved I was able to get to the server but then the shell would hang on the last step of getting into the server. I see the welcome message of the server but I can not execute commands nor use the shell as if I am in the server, never seen that before!

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

It looks like this is a digital ocean specific issue, and not due to my catalina update, the issue I ran into is described here, scroll to section SSH hangs. `Possible cause

With some routers behind NAT and when using OpenSSH. During session setup, after the password has been given, OpenSSH sets the TOS (type of service) field in the IP datagram. The router choke on this. The effect is that your SSH session hangs indefinitely. In other words, SSH commands or connections are seldom working or not working at all.


So I just found that I need to add -o IPQoS=throughput to my ssh flags and that solved the problem!