Question

Why 127.0.0.1:8080/wp jump into 127.0.0.1/wp automatically?

My wordpress was built on 80 port of apache2. Now i change apache2 configuration file,to make port 80 into 8080, everytime i input 127.0.0.1:8080/wp in the firefox ,it jump into 127.0.0.1/wp automatically, in order to visit my post,i have to input url in the form of http://127.0.0.1:8080/wp/?p=1938 ,it will not jump into http://127.0.0.1/wp/?p=1938,i wander what result in the jump from 127.0.0.1:8080/wp into 127.0.0.1/wp . it is the cache in apache or cache in firefox?If it is the cache in apache that result in the fact,how to close the cache function in apache2(in debian8)?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This question was answered by @Archie22is:

Hi there,

There shouldn’t be a need to edit ports. In your database, you simply need to update:

site_url
home_url 

The options can be found in the wp_options table. Let me know if you require anything else.

View the original comment