AzureWolf
By:
AzureWolf

Wordpress Ulysses Mac Setup

September 30, 2016 975 views
WordPress Ubuntu 16.04

Hi everyone,

I am using a mac and I would like to use Ulysses to publish to my Wordpress site.

I setup a Wordpress site using one-click setup, and everything is perfect. I'm happy with the outcome, and I don't think there is any issue on Wordpress end. However, when I try to add the Wordpress account to Ulysses for Mac, it fails.

I contacted the company behind Ulysses and they said, "use SSL, lol." When I said I tried that with no change, they stopped responding. I have tried asking them for some response and still have received absolutely nothing.

The error it reports is, "Failed to login. Please verify the URL of your blog." This occurs regardless of whether I put in a correct username and password or not. The thing is, if I use an invalid certificate, it asks if it should trust the invalid certificate, so the error is clearly bogus.

I am wondering if there's anything I need to enable on the barebones Wordpress setup I currently have to make other services connect? I figured I'd ask, especially if someone had the same plan as I.

Thanks for your help. I paid too much for this app and their silence to their customers has made me sure to not recommend them. On the other hand, digitalocean has been nothing short of awesome every time I've asked for help, so I'm hoping someone can help me out even though this is not an issue directly related to them (and the answer may help someone out in the future!).

Thank you!

3 Answers

I am sorry you're running into these problems and that nobody followed up with you sooner. I am guessing that they encountered the same issue I did. Ulysses only launched WordPress publishing recently and there don't seem to be (that I could find) any documentation available on how it is connecting or publishing. Because it is only asking for WordPress credentials my guess is that it is using the xmlrpc service in WordPress. This service is also a major target for attackers trying to gain access to WordPress blogs and servers. While we have never blocked access to this by default we have taken some steps to restrict it.

If you are using our new 16.04 based WordPress one-click there is a fail2ban service running which attempts to block malicious access to the xmlrpc.php service. You can disable this to check if it is causing the issue by running service fail2ban stop.

  • Thanks for getting back to me! I was working with your AWESOME support team on this issue and solved it thanks to their help. Like you, they realized it's related to XML-RPC and were able to help guide me the right way.

    For whatever reason, stopping fail2ban didn't resolve it. It seems to be something about php7.0 not be properly registered, so sudo apt-get purge php7.0-xml && sudo apt-get install php7.0-xml fixes it.

    Thanks for having an awesome community and team! Everyone is so helpful!

Thanks a lot! I'm facing the same problem, and I solved with the method above. It really works.

Please also consider fix it in wordpress one-click image.

I'm having the exact same problem now with Ulysses 2.7.2 and the above command doesn't work for me. Does anyone else have any further steps to correct the issue?

  • Can you let me know a little bit more about what is going on? What is the output when you run the command?

    • There's no errors from the command - it seems to run successfully on the server - however the message in Ulysses remains the same as reported by the original poster. I've tried to reboot my server to no avail, I'm just getting the same generic 'Failed to login. Please verify the URL of your blog.' message through the app.

      • I'm out of ideas. I checked the version I have and it's 2.7.2. I would suggest seeing if you can connect using another client that uses XML-RPC and see if it works. If so, then the issue is somewhere within Ulysses; if not, wordpress is probably the issue.

        Last thing I figure: make sure you have https:// instead of http:// and you have enabled a letsencrypt certificate.

        Sorry I couldn't help more. :-/

Have another answer? Share your knowledge.