Question

Your database login does not have the privileges to create table on the database "defaultdb".

Another problem with Digitalocean DB cluster When i’m trying to install Prestashop on new droplet Ubuntu 1.8.0.4 LTS, PHP 7.3, MySQl 8, i got this error during installation step test database connection

Your database login does not have the privileges to create table on the database "defaultdb".

That if i’m using doadmin user with defaultdb database

But if i’m using another DB user with another database then i got this error

Your database login does not have the privileges to create table on the database "ps17dev01". Ask your hosting provider:
Storage engine MyISAM is disabled (Table creation is disallowed).

Before i can doing this, i was altering the authentication method from to mysql_native_password because somehow if using the default authentication method which is caching_sha2_password i can’t connect to my DB cluster via my Droplet.

How to fix this problem ? How to Create New Database and associate specific user to the database from DB cluster Control Panel Tab Users & Databases ?

Why it’s so complicated to use Digitalocean MySQL DB cluster ?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

It looks like PrestaShop is failing to pick up the correct MySQL engine storage and is defaulting to MyISAM which is disabled on the managed MySQL cluster.

To fix that you could do the following:

Edit this file:

classes/db/DbPDO.php
  • Look for the following:
if ($engine === null) {
        $engine = 'MyISAM';
    }
  • And update it to:
if ($engine === null) {
        $engine = 'InnoDB';
    }

Hope that this helps! Regards, Bobby