// Tutorial //

Pacman -Syu Kernel Update [SOLVED]: How to Ignore Arch Kernel Upgrades

Published on September 28, 2012
Default avatar
By Etel Sverdlov
Developer and author at DigitalOcean.
Pacman -Syu Kernel Update [SOLVED]: How to Ignore Arch Kernel Upgrades

Arch offers its updates on a rolling release schedule. Arch linux is updated to the newest version with the command:

pacman -Syu

Arch linux will overwrite the kernel when the upstream maintainers release a new kernel package. In many instances, especially in a virtualized environment, where the kernel might be located outside of the running server, it is necessary to tell pacman to ignore upgrading the linux kernel.

To do so, add this line to the pacman configuration file, /etc/pacman.conf:

IgnorePkg   = linux

Once this line is modified, any future updates to the system will skip the kernel overwrite.

By Etel Sverdlov

If you’ve enjoyed this tutorial and our broader community, consider checking out our DigitalOcean products which can also help you achieve your development goals.

Learn more here


About the authors
Default avatar
Developer and author at DigitalOcean.

Still looking for an answer?

Was this helpful?
10 Comments

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Hello, how do I ignore two package? adding a coma or just a space?

@justin: Unfortunately we do not support using your own kernels currently.

I would also like to be able to run a recent kernel, some things such as iptables breaks when you update it and don’t update to the corresponding kernel.

Do small tut for myself maybe somebody this help See here https://github.com/helirexi/LEMP-VPS-DigitalOcean

To the above post – in ===code=== second string is ONE long line! not two!

How to use last kernels in Digital Ocean droplet

@Sean commented · June 10, 2013 4:29 p.m. This is how I set up my own kernels. (try at your own risk) http://www.youtube.com/watch?v=LHNPTvMwHPE

Following to Sean video (see his post with youtube video) made this with my arch droplet - and very happy! Finally I have normal (not-Frankenstein) arch system as arch naturally is - always up-to-date! Big Thanks, Sean!

There few steps.

Switch to root (if you have sudo installed): sudo su

Install kexec-tools: pacman -S kexec-tools -y

Remove systemd-sysvcompat: pacman -R systemd-sysvcompat

Make you own boot script: nano /tmp/init ======code====================== #!/bin/sh

kexec --load /boot/vmlinuz-linux --initrd=/boot/initramfs-linux.img --append=“root=LABEL=DOROOT init=/usr/lib/systemd/systemd” &&

mount -o ro,remount / &&

kexec -e

exec /usr/lib/systemd/systemd ======end==code========================

Change dir: cd /sbin

Copy our script: cp /tmp/init ./

Make it executable: chmod 0755 init

Go to pacman.conf and enable kernel updates: nano /etc/pacman.conf

… #IgnorePkg = linux …

Change line ‘IgnorePkg = linux’ - comment it with # (and save file!)

Then update system: pacman -Syu

And after reboot you droplet (‘sudo reboot’ not work after remove systemd-sysvcompat): systemctl reboot

Check now you kernel (uname -a) and happy!

Hello, why is this marked as [SOLVED] ? It’s not solved at all, it’s just ignored.

It’s not right if I can’t naturally upgrade the kernel at all.

I would really like to have newer kernels too.