Question

Adding new account in WHM not working.

Hi Guys,

Im a newbie here.

I installed cpanel(trial version) on my first droplet. Point my first website and mail which is working, no problem at all.

But when I tried to add a new domain under WHM->Create a New Account which is all went fine. But I cannot access this newly created account using the domain name.

Here is my set up:

  1. Added the new domain to my WHM. (assuming domain.com)
  2. change the nameserver of domain.com in godaddy.com to point here: NS1.DIGITALOCEAN.COM, NS2.DIGITALOCEAN.COM, NS3.DIGITALOCEAN.COM

But when I tried to access the domain.com on my browser it says “server not found”. Is there anything I need to configure to make this domain.com work?

Thanks, Myke


Submit an answer
Answer a question...

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

alexdo
Site Moderator
Site Moderator badge
November 20, 2020
Accepted Answer

Hello, all

You need to do is to allow the creation of remote domains via WHM’s Tweak Settings.

Login to WHM –> Server Configuration –> Tweak Settings –> Domains tab and look for the Allow Remote Domains and enable it.

Allow creation of parked/addon domains that resolve to other servers (e.g. domain transfers) This can be a major security problem. If you must have it enabled, be sure not to allow users to park common Internet domains.

Once this is enabled just go ahead and add your domain.

Hope that this helps! Regards, Alex

I had the same problem as you when I started at DO. What solve my problem was set up vanity name servers. So basically every time you want to point a domain to your droplet the name servers will be ns1.yourdomain.com and ns2.yourdomain.com (yourdomain.com being the domain that is assigned to your droplet)