Apache2 Default root directory

I am facing some issues with Apache2. I have installed the full LAMP stack, which is working fine together with virtual hosts/domains.

But when I try to edit the default (“000-default.conf”) document root directory, the Apache2 Ubuntu Default Page is always showing. I have tried to restart the apache2 service, and I even tried to remove index.html page, located at var/www/html/index.html (which seems to contain the default file) but no luck. The Default Apache2 Ubuntu page always shows up, when I enter the IP of the server.

Any ideas why this might happen?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Without seeing your configuration it would be very difficult to troubleshoot it. The fact that pages continue to show up after you have deleted them (to the best of my knowledge there is only a single copy of the default index.html file) I would check that your local cache is cleared in your browser and that the network you are on is not doing any caching of it’s own as a cache storing a static copy of the site somewhere between you and it sounds like the most likely reason for what you’re seeing.