Apache2 on Ubuntu 18.10 all sites respond with ERR_EMPTY_RESPONSE (ping works)

March 24, 2019 433 views
Apache PHP Ubuntu

Hi everyone,

I recently installed several applications on an Ubuntu 18.10 droplet. They work fine for a while, but after a few minutes I start getting errors on all requests to the applications:

This page isn’t working
xxx.com didn’t send any data.
ERREMPTYRESPONSE

However, if I ping the sites they respond correctly.

If I do a sudo tail /var/log/apache2/error.log I get the following errors all the time:

[Sun Mar 24 23:07:32.431672 2019] [proxy_fcgi:error] [pid 877:tid 139937659733760] (70007)The timeout specified has expired: [client 2605:de00:1:1:4a:4a:0:2:51906] AH01075: Error dispatching request to : (polling)

I tried restarting Apache, rebooting the droplet… but I don’t know what I’m missing, Any ideas?

Thanks in advance

1 Answer
jarland MOD March 25, 2019
Accepted Answer

Greetings!

It looks like you’re using mod_fcgid, and the back-end application is not responding before the timeout value. Raising the timeout is certainly an option, and it can be a stand-in solution for the moment, but I have a problem with calling it “the” solution. If a timeout has to be extended to load a website, then I propose that said website needs to have it’s code reviewed for performance issues. You want your website to be fast, and this is evidence that it is not.

With that said, let’s go ahead with the idea of increasing the timeout. I do not know what configurations you’ve made, so I will suggest doing this to identify where the configurations may be:

grep -R "Fcgid" /etc/apache2

This should reveal what files have that string in them. You may find many different variables with timeout values assigned. You can find a reference to each one of these variables and how they can be configured here:

https://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html

Jarland

Have another answer? Share your knowledge.