Azure blob storage has been implemented but its content type in the cloud showing octet-stream issue

Hi Team

I have implemented azure blob storage plugin in our project, and we have uploading multiple extension files like image pdf etc to the cloud, but in the cloud it shows content type as octet-stream. i have tried setting content type in stream_flush method, but it doesnt work.

i have tried adding additional params to the azure api createBlockBlob but it doesnt take extra params.

which method of the stream i have to set the content type? can anyone please suggest how to pass content type of the uploading file to the cloud ?

please help me to solve this issue.

thanks in advance

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Bobby Iliev
Site Moderator
Site Moderator badge
October 19, 2023
Accepted Answer

Hi there,

When you’re uploading files to Azure Blob Storage using the SDK, you can specify the ContentType property to ensure that the blobs have the appropriate content type. If you don’t specify this property, Azure Blob Storage might default to using application/octet-stream as the content type.

So before uploading the file, find out what its content type is. For a PHP project, you should be able to use the finfo function to detect the MIME type of a file:

$finfo = finfo_open(FILEINFO_MIME_TYPE);
$contentType = finfo_file($finfo, $filePath);

And then when you upload the file to Azure Blob Storage, specify the content type:

$blobClient = BlobRestProxy::createBlobService($connectionString);

// Set blob options with content type
$blobOptions = new CreateBlockBlobOptions();

// Upload the file
$blobClient->createBlockBlob($containerName, $blobName, fopen($filePath, 'r'), null, $blobOptions);

Hope that this helps! If this still does not work, feel free to share more details about your setup and I will try to advise you further!



Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel