Question

BadDigest 400 on Uploading Chunk to the Bucket

I am getting an error of Bad Digest code 400 when uploading the chunk, I looked into the header I am sending and it looks fine I am using v2 signature bcoz v4 doesn’t seem to work. Here is the header I am sending, the header works when I Initiate the Multipart upload but gives error of BadDigest on upload. Have added the header below its serialized.

Array
(
    [0] => Host: sgp1.digitaloceanspaces.com
    [1] => Date: Fri, 30 Sep 2022 08:17:53 GMT
    [2] => Content-MD5: dL3kbSLQpfTwhAS92Q4y1w==
    [3] => Content-Type: application/octet-stream
    [4] => Authorization: AWS [REDACTED]:[REDACTED]
)

And please someone fix the bug of the pop-up on the community, it appears on every refresh.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Fixed it and found out the issue was https. Most of my requests were through HTTP so after making it to https it worked. But its weird that you can initiateMultipartUpload with HTTP but you can’t upload part with HTTP. Is there a reason for that?

Hi there,

One thing that I’ve noticed is that the bucket name is missing from the request header.

Can you share your the code snippet that you are using so I could take a further look and possibly try and reproduce this on my end?

Best,

Bobby