Question

Can send but not receive email (CentOS, Postfix)

I followed the instructions here to set up PostFix and I now have mail being sent from my website working just fine. https://www.digitalocean.com/community/articles/how-to-install-postfix-on-centos-6

However I cannot receive emails.

I added an A and MX record for the mail server a few days ago.

I would like to either set up multiple user accounts to run from outlook (need passwords on each etc. so may be more complex) or just have everything get forwarded to free gmail accounts.

In postfix main.cf I have:

virtual_alias_maps = hash:/etc/postfix/virtual

in /etc/postfix/virtual I have a line for each intended email address and where it should forward e.g.:

me@mydomain.com me@gmail.com

Then I did this:

postmap /etc/postfix/virtual

service postfix reload

But I get nothing, any ideas?

Thanks


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

same problem here

Gone through the whole process, still cannot receive email. Emails are sent, but cannot receive. Here are my MX records: <br> <br>A @ 198.199.125.224 <br>CNAME www @ <br>CNAME * @ <br>NS NS1.DIGITALOCEAN.COM. <br>NS NS2.DIGITALOCEAN.COM. <br>NS NS3.DIGITALOCEAN.COM. <br> <br>Followed Etel Sverdlov’s tutorial on setting up Postfix & Cyrus on Centos 6.

This solved it for me, for those searching the web for hours.

sudo vim /etc/postfix/main.cf – press i – go to inet_interfaces – set inet_interfaces to all sudo service postfix restart