May 25, 2012

Advanced

How To Install Postfix on CentOS 6

Tagged In: Linux Basics

About Postfix


Postfix is free open source Mail Transfer Agent which works to route and deliver email. Cyrus is a server that helps organize the mail itself.

Step One —Install Postfix and Cyrus


The first thing to do is install postfix and Cyrus on your virtual private server and the easiest way to do this is through the yum installer.
sudo yum install postfix
sudo yum install cyrus-sasl
sudo yum install cyrus-imapd

Say Yes to the prompt each time it asks. Once all components have downloaded, you will have postfix and cyrus installed.

Step Two—Configure Postfix


We are going to configure both programs separately.

First, open up the Postfix’s main configuration file.
sudo vi /etc/postfix/main.cf

The postfix configuration file is very handy and detailed, providing almost all of the information needed to get the program up and running on your VPS. Unfortunately this also makes for a very long file.

The suggested code below is, in most regards, simply a shortened, and correctly uncommented version of what is in the file already. For a quick set up that will provide you with all of the needed configs to set up postfix, copy and paste the information below over Postfix's current configuration. Be careful to correct the domain names under myhostname and mydomain.

Replace the example.com in the myhostname line with a DNS approved domain name. Be sure that the phrase is still mail.yourdomainnamehere

Replace the example.com in the mydomain line with the correct domain name.
soft_bounce             = no
queue_directory         = /var/spool/postfix
command_directory       = /usr/sbin
daemon_directory        = /usr/libexec/postfix
mail_owner              = postfix

# The default_privs parameter specifies the default rights used by
# the local delivery agent for delivery to external file or command.
# These rights are used in the absence of a recipient user context.
# DO NOT SPECIFY A PRIVILEGED USER OR THE POSTFIX OWNER.
#
#default_privs = nobody

myhostname              = mail.example.com 
mydomain                = example.com

mydestination           = $myhostname, localhost
unknown_local_recipient_reject_code = 550

mynetworks_style        = host
mailbox_transport       = lmtp:unix:/var/lib/imap/socket/lmtp
local_destination_recipient_limit       = 300
local_destination_concurrency_limit     = 5
recipient_delimiter=+

virtual_alias_maps      = hash:/etc/postfix/virtual

header_checks           = regexp:/etc/postfix/header_checks
mime_header_checks      = pcre:/etc/postfix/body_checks
smtpd_banner            = $myhostname

debug_peer_level        = 2
debugger_command =
         PATH=/bin:/usr/bin:/usr/bin:/usr/X11R6/bin
         xxgdb $daemon_directory/$process_name $process_id & sleep 5

sendmail_path           = /usr/sbin/sendmail.postfix
newaliases_path         = /usr/bin/newaliases.postfix
mailq_path              = /usr/bin/mailq.postfix
setgid_group            = postdrop
html_directory          = no
manpage_directory       = /usr/share/man
sample_directory        = /usr/share/doc/postfix-2.3.3/samples
readme_directory        = /usr/share/doc/postfix-2.3.3/README_FILES

smtpd_sasl_auth_enable          = yes
smtpd_sasl_application_name     = smtpd
smtpd_recipient_restrictions    = permit_sasl_authenticated,
                                  permit_mynetworks,
                                  reject_unauth_destination,
                                  reject_invalid_hostname,
                                  reject_non_fqdn_hostname,
                                  reject_non_fqdn_sender,
                                  reject_non_fqdn_recipient,
                                  reject_unknown_sender_domain,
                                  reject_unknown_recipient_domain,
                                  reject_unauth_pipelining,
                                  reject_rbl_client zen.spamhaus.org,
                                  reject_rbl_client bl.spamcop.net,
                                  reject_rbl_client dnsbl.njabl.org,
                                  reject_rbl_client dnsbl.sorbs.net,
                                  permit

smtpd_sasl_security_options     = noanonymous
smtpd_sasl_local_domain         = 
broken_sasl_auth_clients        = yes

smtpd_helo_required             = yes 

Step Three— Finalize Postfix


After pasting in the proper configs, we are almost finished setting up postfix on our virtual server.

To forestall any errors, we need to execute two more steps

In the config we included virtual aliases with the line, virtual_alias_maps = hash:/etc/postfix/virtual; now we have to set up that database.

Open that file:
sudo vi /etc/postfix/virtual

Delete all the text within the file and then add the following single line, substituting an actual username for user, and the correct domain for example.com:
[email protected]   user\@example.com

Save and exit.

Follow up by typing in this into terminal
postmap /etc/postfix/virtual 

This will turn the virtual file into a lookup table, creating the database required for postfix to work.

Finally conclude by using this command, which will create the new file that postfix expects before sending anything out.

touch /etc/postfix/body_checks 

Once all that is completed we can finish up by configuring Cyrus.

Step Four—Configure Cyrus


The first step is to add the smtpd.conf file, which defines the authentication for Postfix/SASL, to the SASL directory:
sudo vi /etc/sasl2/smtpd.conf

Go ahead and copy and paste the following text in:
pwcheck_method: auxprop
auxprop_plugin: sasldb
mech_list: PLAIN LOGIN CRAM-MD5 DIGEST-MD5 

Save and Exit.

Next, we need to configure the Cyrus file:
sudo vi /etc/imapd.conf

Delete what is in the file currently, and paste the configurations below into the file, changing the default domain and server name to match your personal domain name.
virtdomains:		userid
defaultdomain:		example.com
servername:		example.com
configdirectory:	/var/lib/imap
partition-default:	/var/spool/imap
admins:			cyrus
sievedir:		/var/lib/imap/sieve
sendmail:		/usr/sbin/sendmail.postfix
hashimapspool:		true
allowanonymouslogin:	no
allowplaintext:		yes
sasl_pwcheck_method:	auxprop
sasl_mech_list:		CRAM-MD5 DIGEST-MD5 PLAIN
tls_cert_file:		/etc/pki/cyrus-imapd/cyrus-imapd.pem
tls_key_file:		/etc/pki/cyrus-imapd/cyrus-imapd.pem
tls_ca_file:		/etc/pki/tls/certs/ca-bundle.crt

autocreatequota:		-1
createonpost:			yes
autocreateinboxfolders:		spam
autosubscribeinboxfolders:	spam 

Save and Exit.

Step Five—Install a Mail Client


Success! You have installed Postfix and Cyrus on your VPS. However, both of these programs relate to handling email rather than sending it. We can quickly install a method of sending messages from the command line.

There are a variety of clients we can use—here we will connect with MailX
yum install mailx

After you agree to the prompt, mailx will finish up installing.

Then, to send emails, type this command into terminal, substituting in the email that you are looking to send your message to.
mail [email protected]

Terminal will ask for a subject line. Type one in, then press enter. On the subsequent lines you can type your message. It will only be sent when you press enter, and type in a period.

Your letter will look something like this:
[root@demoserver ~]# mail [email protected]
Subject: Hello
This is a test message.
Regards,

.
EOT 

Congratulations—now you have postfix installed and email running. You are all set to use your virtual private server to send email.

By Etel Sverdlov

Share this Tutorial

Vote on Hacker News

Try this tutorial on an SSD cloud server.

Includes 512MB RAM, 20GB SSD Disk, and 1TB Transfer for $5/mo! Learn more

Create an account or login:

76 Comments

Write Tutorial
  • Gravatar Craig Avnit about 1 year

    If you are using Google Public DNS in /etc/resolv.conf which is the default, you will need to change it as Spamhaus does not work with Google Public DNS servers.

  • Gravatar Fernando Vieira about 1 year

    Greate article. Really easy to follow these steps. But, how about multiple domains in the same server?

  • Gravatar s4ad-dev 11 months

    did not work for me

  • Gravatar Kamal Nasser 11 months

    @Fernando Vieira Postfix's Virtual Domains feature should help: http://www.akadia.com/services/postfix_separate_mailboxes.html @s4ad-dev What exact problem are you experiencing?

  • Gravatar willywg 11 months

    Good tutorial. But I has a problem. sudo cat /var/log/maillog and get: May 23 14:27:01 Deambula postfix/smtpd[22748]: fatal: no SASL authentication mechanisms I solve this intalling: sudo yum install cyrus-sasl-plain

  • Gravatar sysadmin 11 months

    I have installed and configure everthing accordingly. but when going to send email and type # mail [email protected] It doesn't prompt for Subject. where can i check this and resolve this. Regards: imran

  • Gravatar Kamal Nasser 11 months

    @imran: you can pass "-s subject" to the mail command.

  • Gravatar kilroy05 10 months

    so this solves sending. how do I read the mail accounts for multiple users / how to set them up in the first place should probably be in this article. back to the docs :)

  • Gravatar Turk 10 months

    servername: mydomain.com that broke my whole thing so i removed it and it worked had me pulling my hair out for like 900 hours

  • Gravatar sunlynx 9 months

    if you got below error: PLAIN [SASL(-13): user not found: Password verification failed] Please try to use saslauthd sudo yum install cyrus-sasl-plain sudo vi /etc/sasl2/smtpd.conf pwcheck_method: saslauthd mech_list: plain login #pwcheck_method: auxprop #auxprop_plugin: sasldb #mech_list: PLAIN LOGIN CRAM-MD5 DIGEST-MD5 sudo vi /etc/imapd.conf #sasl_pwcheck_method: auxprop #sasl_mech_list: CRAM-MD5 DIGEST-MD5 PLAIN sasl_pwcheck_method: saslauthd sasl_mech_list: PLAIN LOGIN CRAM-MD5 DIGEST-MD5 sudo /etc/rc.d/init.d/postfix start sudo chkconfig postfix on sudo chkconfig --level 345 cyrus-imapd on sudo /sbin/service cyrus-imapd start sudo /etc/init.d/saslauthd start sudo chkconfig saslauthd on check sasl module /usr/sbin/pluginviewer Testing: testsaslauthd -u mailusername -p mailpassword /usr/bin/imtest -u mailusername -a mailusername -w mailpassword domain.com

  • Gravatar meelis 9 months

    Would that conf. also work for Ubuntu?

  • Gravatar Kamal Nasser 9 months

    @meelis: No, this article is specific to CentOS only. You can follow this article on Ubuntu: https://www.digitalocean.com/community/articles/how-to-install-and-setup-postfix-on-ubuntu-12-04

  • Gravatar meelis 9 months

    Theproblem is, it does not feature the installation of GUI. Postfix itself works, yes:)

  • Gravatar bluethrustweb 9 months

    Sending mail works, except receiving mail isnt. Do you also need to set up mx records for the receive part to work? If so how? Thanks!

  • Gravatar Kamal Nasser 9 months

    @bluethrustweb: You have to add an MX record if you want to receive mail. Create an A record called 'mail' that points to your droplet's IP address. Then, create an MX record with 'mail' as the hostname, and 5 as the priority.

  • Gravatar jasebase 8 months

    Hello! You have the word "postfix" spelt with a capital "P" in the command in Step One - which of course will return an error, "No package Postfix available."

  • Gravatar Kamal Nasser 8 months

    @jasebase: Good catch! Updated the article. :]

  • Gravatar sunlynx 8 months

    Note : 64bit CentOS Cyrus SASL searches /usr/lib/sasl2/ first. If it finds the specified configuration file there, it will not examine other locations. but 64bit CentOS doesn't have this directory. after ln -s /usr/lib64/sasl2/ /usr/lib/sasl2 all steps work fine. ignore my previous post.

  • Gravatar Thomas McMahon 8 months

    This does not work for me. The help file seems out of date as everything in the postfix config file doesn't seem to exist from smtpd_sasl_auth_enable on down.

  • Gravatar Kamal Nasser 8 months

    @Thomas: Some of the config directives are not included in the default config file. Try replacing it with the contents in the article -- it should work fine.

  • Gravatar callumpy 8 months

    I can send mail from the console, but I just can't use the SMTP from my mail client externally, it's driving me mad, I can't work out what is causing it!

  • Gravatar Kamal Nasser 8 months

    @callumpy: Do you get any errors when trying to connect to your droplet's SMTP service?

  • Gravatar wicked 8 months

    Hi, I am experiencing issues while trying to send mail. Here is the log file, any help would be appreciated! http://pastebin.com/vLzz8Mc7

  • Gravatar Kamal Nasser 8 months

    @wicked: Take a look at this page: https://support.google.com/mail/answer/6592?hl=en

  • Gravatar maximoishi 7 months

    how can i get available by mail.domain.com ?? where i can configure more user/password acc and make t available from external scripts SMTP copnn

  • Gravatar Kamal Nasser 7 months

    @maximoishi: This article walks you through setting up postfix and not a webmail client. I suggest you try iRedMail instead on a fresh droplet: https://www.digitalocean.com/community/articles/how-to-install-iredmail-on-centos-6-3-x64

  • Gravatar oSiNaReF 7 months

    Delete previus post. @KamalNasser I tried to creat the records necessary for my host. They are correct? A Record: Hostname=mail IP=(my IP) MX Record: Hostname=mail.(mydomain.com). Priority=5 Is correcto hostname of MX record?

  • Gravatar Kamal Nasser 7 months

    @oSiNaReF: The Hostname of the MX record should be "mail".

  • Gravatar maximoishi 7 months

    @kamal Nasser im trying to connect from my localhost PC to my remote smtp server but i dont know what i need to setup in my vps im trying: mail.iadrian.pe user pass but i just get: Send Error There was an error while trying to send the test email. Please check the connection details.

  • Gravatar Kamal Nasser 7 months

    @maximoishi: You have sendmail running. Try removing it and rebooting your droplet:

    yum remove sendmail && shutdown -r 0

  • Gravatar maximoishi 7 months

    @Kamal Nasser after this can i follow up this tutorial?

  • Gravatar maximoishi 7 months

    @kamal wiiiuu i did now im sending emails from local :D just testing purpose not spam, well i had an extra work steps from @sunlynx Thank you both are amazing!

  • Gravatar Kamal Nasser 7 months

    Awesome! :]

  • Gravatar jeff.dewit 6 months

    This worked great for me except Cyrus wasn't running so I had to start it before I was able to send an email: /etc/init.d/cyrus-imapd start And if you want it to start at boot: chkconfig --level 3 cyrus-imapd on

  • Gravatar kabat.juraj 6 months

    Kamal, I have troubles to connect to correct mailboxes using GMAIL POP3 feature. Before this setup, I have been receiving mails to /var/spool/mail, then after IMAP setup I started receiving mails directed to [email protected] to /var/spool/imap/domain/m/mail.example.com/m/user/mike/ but now somehow I cant find mails anywhere. Using GMAIL POP3 option I can connect but I retrieve nothing. main.cf home_mailbox = Maildir/ mail_spool_directory = /var/spool/mail mailbox_transport = lmtp:unix:/var/lib/imap/socket/lmtp imapd.conf virtdomains: userid partition-default: /var/spool/imap Don't you know what could be the problem?

  • Gravatar kabat.juraj 6 months

    Hmm, you can ignore my previous post - seems like the issue was with my patience... I have updated DNS record before configuring and it took some time while it all started working.

  • Gravatar Vince Kronlein 5 months

    Worked perfectly! Great job thanks so much.

  • Gravatar Pablo of vDevices.com 5 months

    If we want to deploy Postfix to be a send-only mail server (e.g., for on-board apps), do we still need to install cyrus-sasl, cyrus-imapd, and/or mailx?

  • Gravatar Pablo of vDevices.com 5 months

    EDIT: Nevermind. I asked b/c I was in the process of writing a tutorial on deploying the FreePBX (and Asterisk) Distro on a DigitalOcean cloud server; but subsequently noticed that the FreePBX distro not only installs Postfix, but also installs cyrus-sasl and mailx. Thus, my new question is: If cyrus-imapd is not installed, does that change anything in this tutorial other than skipping over the section related to editing the /etc/imapd.conf file?

  • Gravatar Kamal Nasser 5 months

    @Pablo: Cyrus is an IMAP server. If you do not want to receive mail you usually do not need to access your droplet via the IMAP protocol so it's not needed. You can install postfix/exim4/any other MTA and have it listen on 127.0.0.1, this way your droplet is send-only :]

  • Gravatar Kamal Nasser 5 months

    So, if cyrus-imapd is not installed, you can skip all of the sections that are related to IMAP/SASL since you won't need them.

  • Gravatar Pablo of vDevices.com 5 months

    Thanks Kamal!

  • Gravatar Brice Lechatellier 5 months

    Kamal, I followed this setup and can send emails and also forward emails when sent from the server directly but anything sent from outside get lost in a blackhole. What's the best way for me to debug please? Thanks!

  • Gravatar Krishna 5 months

    i have configured postfix but i couldn't able to send via SMTP so kindly help me out

  • Gravatar Kamal Nasser 5 months

    @brice: What's the output of

    sudo netstat -plutn | grep 25
    ? Also, what's the domain name?

  • Gravatar Kamal Nasser 5 months

    @Krishna: How are you trying to send mail via SMTP? Is postfix running (sudo netstat -plutn | grep 25)?

  • Gravatar leongoogs 4 months

    This has been a great help , thanks . Seems I still have a permissions issue after following this . So need a little help . I get , [/var/lib/imap/socket/lmtp]: Permission denied . Originally the lmtp had not been created , so created it . Permissions are for the cyrus iMAP server and the group is mail , SElinux is for cyrus_var_lib_t . I am guessing Postfix is having trouble writing to the directory , Any clues pls

  • Gravatar leongoogs 4 months

    Cleared up the writing problem now it is Connection refused

  • Gravatar leo 4 months

    I got problem when sending email from mobile, I check the /var/log/maillog it says postfix/smtpd[12714]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory postfix/smtpd[12714]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory postfix/smtpd[12714]: warning: SASL authentication failure: Password verification failed postfix/smtpd[12714]: warning: unknown[114.4.23.37]: SASL PLAIN authentication failed: authentication failure Any help would be appreciated

  • Gravatar Kamal Nasser 4 months

    @leo: Try rebooting your droplet, does that fix it?

  • Gravatar SupaHam.me 4 months

    So I followed this tutorial and sending mails works fine, but I can't seem to figure out which part in the whole tutorial explains where you set your password, when I try to log in with user: [email protected] pass: (username's password) it says wrong password.

  • Gravatar SupaHam.me 4 months

    I figured it out, I forgot to set my server name in my mail client.

  • Gravatar swagatoatwork 4 months

    Hello, after installing and configuring I was getting error as mention by @sunlynx earlier in this post and followed his mentioned method and it worked. I have installed Squirrelmail and Roundcubemail, when I logged in I found there is no sent, draft, trash folder. Could you help on this?

  • Gravatar swagatoatwork 4 months

    I am getting the following error where folders were supposed to be. ERROR: ERROR: Could not complete request. Query: CREATE "Sent" Reason Given: Permission denied

  • Gravatar tgerencer 3 months

    Hi Kamal, This did not work for me. I think it's because my hostname is of the variety ip-192-0-2-0.secureserver.net. I think I may need to change it but I'm terrified this will break my whole server. Any advice? I have a VPS with GoDaddy.

  • Gravatar Kamal Nasser 3 months

    @tgerencer: Which part doesn't work?

  • Gravatar tgerencer 3 months

    Thank you Kamal. Well actually the part in this tutorial probably works. However, I'm attempting to relay my mail from my VPS through GoDaddy's relay mail server. Every time I try to set up the relay connection, the connection times out. Here's my error log (real info omitted) Jan 31 12:47:47 ip-192-0-2-0 postfix/smtp[30026]: connect to dedrelay.secureserver.net[nn.nn.nn.nn]:587: Connection timed out Jan 31 12:47:47 ip-50-63-67-112 postfix/smtp[30026]: ADA711FD371: to=, relay=none, delay=30, delays=0.02/0.01/30/0, dsn=4.4.1, status=deferred (connect to dedrelay.secureserver.net[nn.nn.nn.nn]:587: Connection timed out) I am able to telnet to that relay mail server, so I think it's something to do with my postfix configuration. I have added the line: relayserver = [dedrelay.secureserver.net]:587 to my main.cf file also.

  • Gravatar tgerencer 3 months

    Actually, it's working now. I was trying to set up port 587 earlier and it was working with relaying emails to Amazon SES, but when I switched to trying to use GoDaddy's email server, I had to switch back to port 25. Thanks!

  • Gravatar tgerencer 3 months

    Though I had another funny problem: My mails kept failing because of a postfix permission denied error. It was denying postfix permission to open main.cf. I tried running postfix set-permissions but it said "README:file not found." Online, I found that one guy realized it was looking for postfix version 2.3.3 but he had 2.6.6 installed. He changed the name of his /usr/share/doc/postfix-2.6.6 file to 2.3.3 and it worked for him. I did the same and restarted and it worked for me too. I worry this will cause other problems down the line though. Have you seen this bug?

  • Gravatar tgerencer 3 months

    Ahhhhhh. You know what it is? The conf file text you tell us to insert above cites 2.3.3 a few times. I bet if I (and you) update that to the latest version (and warn people about this for future reference) that problem will be solved!

  • Gravatar Kamal Nasser 3 months

    @tgerencer: Glad you managed to figure it out! I'll update the article to highlight these lines in red.

  • Gravatar tgerencer 3 months

    Thanks Kamal! Great article! So happy to have postfix up and running and my mails going out!

  • Gravatar sales 3 months

    Hi, I get 554 5.7.1 : Relay access denied [655 ms] when attempting to check using mxtoolbox.com I am running CentOS 6 using postfix 2.6.6

  • Gravatar sales 3 months

    250-PIPELINING 250-SIZE 10240000 250-VRFY 250-ETRN 250-AUTH PLAIN CRAM-MD5 DIGEST-MD5 LOGIN 250-AUTH=PLAIN CRAM-MD5 DIGEST-MD5 LOGIN 250-ENHANCEDSTATUSCODES 250-8BITMIME 250 DSN [655 ms] MAIL FROM: 250 2.1.0 Ok [655 ms] RCPT TO: 554 5.7.1 : Relay access denied [655 ms] MXTB-PWS3v2 3541ms

  • Gravatar Kamal Nasser 2 months

    @sales: What isn't working for you?

  • Gravatar sales 2 months

    I can send via terminal using mail command to a remote address however, I cannot receive mail even from a local user. I have ports 25/465/587 open. This is the message i get when I use mxtoolbox to test my mail server: MAIL FROM: 250 2.1.0 Ok [655 ms] RCPT TO: 554 5.7.1 : Relay access denied [655 ms]

  • Gravatar Jason 2 months

    I'm on Ubuntu and I'm having the same Relay access problem as sales -- would really like an answer on this one. Is Postfix only for sending emails out, not receiving them?

  • Gravatar shimon.shv 2 months

    I followed this tutorial but I cannot receive mails. The Delivery Status Notification that I get is: The error that the other server returned was: 550 5.1.1 : Recipient address rejected: User unknown in virtual alias table (I have a correct MX settings and in /etc/postfix/virtual I have "[email protected] mydomain.com/user")

  • Gravatar Nando Penteado 2 months

    Kamal, Wouldn't it be good to have a last step starting services? Something like: # service cyrus-imapd start # /sbin/service postfix start (or stop and start, or reload) # chkconfig --level 345 cyrus-imapd on (and this to start daemon on reboot) and a statement to start postfix too on reboot? Well, I'm even asking this because I don't know if that is the right way to start the server, but it seems to me that it is... best regards, Nando Penteado

  • Gravatar matthew06854 about 1 month

    Having a rough go getting postfix to receive e-mail. I followed the instructions above and am able to successfully send e-mail via terminal to external (non origination domain) recipients, but when I try and send to 1 of 3 internal (origination domain) recipients, I receive the following message in an Undelivered Mail Returned to Sender : : mail for xyzdomain.com loops back to myself So I verified postfix is running Checked main.cf : myhostname = mail.xyzdomain.com mydomain = xyzdomain.com mydestination = $myhostname, localhost.$mydomain, localhost NOTE: I also tried - mydestination = $myhostname, localhost A and MX records : MX 5 mail.xyzdomain.com. mail IN A 199.911.411.311 NOTE: I also tried MX 5 mail Any suggestions greatly appreciated. Thanks.

  • Gravatar Richard Aljaste about 1 month

    When i have entered the subject and pressed enter, i got nothing, just blackness.

  • Gravatar Kamal Nasser about 1 month

    @Richard: That's where you enter the body. Once you're done, press enter and ctrl-d.

  • Gravatar techspecx about 1 month

    Thank you for this tutorial - worked perfect! For the cyrus editing I just didn't have an /etc/imapd.conf file so I created one.

  • Gravatar amudhan.karuna about 1 month

    Hello Kamal, Everything worked correctly. I gave till last (Till EOT) but I didnt receive and mail. What happened?? I want to receive a mail from my gmail id. So should I give the domain name as mail.gmail.com ? How to configure to receive mail from one gmail to other gmail id??

  • Gravatar jfcote 15 days

    I got problems getting emails. The IMAP login works fine : imtest -t "" -p imap -m plain -a jfcote -u jfcote 127.0.0.1 results with : S: A01 OK [CAPABILITY IMAP4 IMAP4rev1 LITERAL+ ID LOGINDISABLED COMPRESS=DEFLATE ACL RIGHTS=kxte QUOTA MAILBOX-REFERRALS NAMESPACE UIDPLUS NO_ATOMIC_RENAME UNSELECT CHILDREN MULTIAPPEND BINARY SORT SORT=MODSEQ THREAD=ORDEREDSUBJECT THREAD=REFERENCES ANNOTATEMORE CATENATE CONDSTORE SCAN IDLE LISTEXT LIST-SUBSCRIBED X-NETSCAPE URLAUTH] Success (tls protection) Authenticated. The SMTP also works fine when sending an email, but locally, when I send myself an email, postfix seems to deliver the email correctly but when I run "mail" in command line, it always outputs "No mail for jfcote"... When sending myself an email, here is the log in /var/log/maillog : Apr 3 12:19:39 tiois postfix/pickup[4366]: 273864068F: uid=0 from= Apr 3 12:19:39 tiois postfix/cleanup[4523]: 273864068F: message-id= Apr 3 12:19:39 tiois postfix/qmgr[812]: 273864068F: from=, size=1634, nrcpt=1 (queue active) Apr 3 12:19:39 tiois lmtpunix[4283]: accepted connection Apr 3 12:19:39 tiois lmtpunix[4283]: lmtp connection preauth'd as postman Apr 3 12:19:39 tiois lmtpunix[4283]: IOERROR: fstating sieve script /var/lib/imap/sieve/domain/m/mail.sirrusdev.com/j/jfcote/defaultbc: No such file or directory Apr 3 12:19:39 tiois lmtpunix[4283]: duplicate_check: mail.sirrusdev.com!user.jfcote 0 Apr 3 12:19:39 tiois master[4527]: about to exec /usr/lib/cyrus-imapd/lmtpd Apr 3 12:19:39 tiois lmtpunix[4283]: duplicate_check: mail.sirrusdev.com!user.jfcote 0 Apr 3 12:19:39 tiois lmtpunix[4283]: Delivered: to mailbox: mail.sirrusdev.com!user.jfcote Apr 3 12:19:39 tiois lmtpunix[4283]: mystore: starting txn 2147483658 Apr 3 12:19:39 tiois lmtpunix[4283]: mystore: committing txn 2147483658 Apr 3 12:19:39 tiois lmtpunix[4283]: duplicate_mark: mail.sirrusdev.com!user.jfcote 1396541979 3 Apr 3 12:19:39 tiois postfix/lmtp[4526]: 273864068F: to=, orig_to=, relay=mail.sirrusdev.com[/var/lib/imap/socket/lmtp], delay=0.06, delays=0.04/0.01/0.01/0.01, dsn=2.1.5, status=sent (250 2.1.5 Ok) Apr 3 12:19:39 tiois postfix/qmgr[812]: 273864068F: removed Apr 3 12:19:39 tiois lmtpunix[4527]: executed Any idea?

  • Gravatar jfcote 15 days

    Some parts have been stripped from my last comment, here is the correct log : http://pastebin.com/Twhg2sC2

Leave a Comment

Create an account or login:
Ajax-loader