Can't get https working on a Wordpress one-click install

September 18, 2016 234 views
WordPress One-Click Install Apps Ubuntu

I've got a Wordpress site set up with one-click.

I followed the various tutorials here and created a self-signed certificate and set it up with an Apache default-ssl.conf file. Apache is reloading, and the certificate is valid, according to (4 As).

So the certificate is valid and Apache works fine.

If I go to my Wordpress site with https, I get redirected to http, and the browser indicates the site is not private/secure.

If I go into my Wordpress settings (or config.php) and change the site and home url to https:// instead of http, if I go to the site (, the page no longer loads - it says it was redirected too many times. BUT I see the green lock in the upper left corner - it is a secure site.

Man I feel like I'm really close - any idea what's going on here?

2 Answers

Try this:
create a file called test.php in your webroot directory

does it work? Getting the green lock? Okay, that means the settings in wordpress need to be updated..might be a plugin

does not work? still getting the redirect error? might be the .htaccess file...try deleting everything in your .htaccess

  • Nope, can't get the green lock at all now. Not sure why I ever got it.

    Tried a fresh .htaccess, with http rewrite:

    RewriteEngine On
    RewriteCond %{HTTPHOST} ^ [NC]
    RewriteCond %{SERVER
    PORT} 80
    RewriteRule ^(.*)$$1 [R,L]

    Nope. Got the endless redirects.

    I removed those lines from .htaccess (and left in the standard rewrite as per the codex) and I left the site and home urls as


    in my config.php - if I enter the site address with https instead of http, it just redirects to http - non-private.


    • Can you post your site config file?

      It should be in /etc/apache2/sites-enabled/

      Also, you should probably be using letsencrypt rather than a self-signed certificate..if you are going to go through the trouble you might as well have a valid certificate.

      If I get time this morning I will post a short walk-through on using acme to get that certificate. I have found it the most simple to use so far.

      • I did use a self-signed certificate. Agree about Let's Encrypt - but I couldn't get it to complete a certificate, so I just did self-signed to get started. I would appreciate a walk-through!

        Here's my default-ssl.conf file (I'm seeing things in here perhaps not set correctly...)

        <IfModule mod_ssl.c>
        <VirtualHost _default_:443>
        DocumentRoot /var/www/html

            # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
            # error, crit, alert, emerg.
            # It is also possible to configure the loglevel for particular
            # modules, e.g.
            #LogLevel info ssl:warn
            ErrorLog ${APACHE_LOG_DIR}/error.log
            CustomLog ${APACHE_LOG_DIR}/access.log combined
            # For most configuration files from conf-available/, which are
            # enabled or disabled at a global level, it is possible to
            # include a line for only one particular virtual host. For example the
            # following line enables the CGI configuration for this host only
            # after it has been globally disabled with "a2disconf".
            #Include conf-available/serve-cgi-bin.conf
            #   SSL Engine Switch:
            #   Enable/Disable SSL for this virtual host.
            SSLEngine on
            #   A self-signed (snakeoil) certificate can be created by installing
            #   the ssl-cert package. See
            #   /usr/share/doc/apache2/README.Debian.gz for more info.
            #   If both key and certificate are stored in the same file, only the
            #   SSLCertificateFile directive is needed.
            SSLCertificateFile  /etc/apache2/ssl/
            SSLCertificateKeyFile /etc/apache2/ssl/server.key
            #   Server Certificate Chain:
            #   Point SSLCertificateChainFile at a file containing the
            #   concatenation of PEM encoded CA certificates which form the
            #   certificate chain for the server certificate. Alternatively
            #   the referenced file can be the same as SSLCertificateFile
            #   when the CA certificates are directly appended to the server
            #   certificate for convinience.
            #SSLCertificateChainFile /etc/apache2/ssl.crt/server-ca.crt
            #   Certificate Authority (CA):
            #   Set the CA certificate verification path where to find CA
            #   certificates for client authentication or alternatively one
            #   huge file containing all of them (file must be PEM encoded)
            #   Note: Inside SSLCACertificatePath you need hash symlinks
            #        to point to the certificate files. Use the provided
            #        Makefile to update the hash symlinks after changes.
            #SSLCACertificatePath /etc/ssl/certs/
            #SSLCACertificateFile /etc/apache2/ssl.crt/ca-bundle.crt
            #   Certificate Revocation Lists (CRL):
            #   Set the CA revocation path where to find CA CRLs for client
            #   authentication or alternatively one huge file containing all
            #   of them (file must be PEM encoded)
            #   Note: Inside SSLCARevocationPath you need hash symlinks
            #        to point to the certificate files. Use the provided
            #        Makefile to update the hash symlinks after changes.
            #SSLCARevocationPath /etc/apache2/ssl.crl/
            #SSLCARevocationFile /etc/apache2/ssl.crl/ca-bundle.crl
            #   Client Authentication (Type):
            #   Client certificate verification type and depth.  Types are
            #   none, optional, require and optional_no_ca.  Depth is a
            #   number which specifies how deeply to verify the certificate
            #   issuer chain before deciding the certificate is not valid.
            #SSLVerifyClient require
            #SSLVerifyDepth  10
            #   SSL Engine Options:
            #   Set various options for the SSL engine.
            #   o FakeBasicAuth:
            #    Translate the client X.509 into a Basic Authorisation.  This means that
            #    the standard Auth/DBMAuth methods can be used for access control.  The
            #    user name is the `one line' version of the client's X.509 certificate.
            #    Note that no password is obtained from the user. Every entry in the user
            #    file needs this password: `xxj31ZMTZzkVA'.
            #   o ExportCertData:
            #    This exports two additional environment variables: SSL_CLIENT_CERT and
            #    SSL_SERVER_CERT. These contain the PEM-encoded certificates of the
            #    server (always existing) and the client (only existing when client
            #    authentication is used). This can be used to import the certificates
            #    into CGI scripts.
            #   o StdEnvVars:
            #    This exports the standard SSL/TLS related `SSL_*' environment variables.
            #    Per default this exportation is switched off for performance reasons,
            #    because the extraction step is an expensive operation and is usually
            #    useless for serving static content. So one usually enables the
            #    exportation for CGI and SSI requests only.
            #   o OptRenegotiate:
            #    This enables optimized SSL connection renegotiation handling when SSL
            #    directives are used in per-directory context.
            #SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire
            <FilesMatch "\.(cgi|shtml|phtml|php)$">
                    SSLOptions +StdEnvVars
            <Directory /usr/lib/cgi-bin>
                    SSLOptions +StdEnvVars
            #   SSL Protocol Adjustments:
            #   The safe and default but still SSL/TLS standard compliant shutdown
            #   approach is that mod_ssl sends the close notify alert but doesn't wait for
            #   the close notify alert from client. When you need a different shutdown
            #   approach you can use one of the following variables:
            #   o ssl-unclean-shutdown:
            #    This forces an unclean shutdown when the connection is closed, i.e. no
            #    SSL close notify alert is send or allowed to received.  This violates
            #    the SSL/TLS standard but is needed for some brain-dead browsers. Use
            #    this when you receive I/O errors because of the standard approach where
            #    mod_ssl sends the close notify alert.
            #   o ssl-accurate-shutdown:
            #    This forces an accurate shutdown when the connection is closed, i.e. a
            #    SSL close notify alert is send and mod_ssl waits for the close notify
            #    alert of the client. This is 100% SSL/TLS standard compliant, but in
            #    practice often causes hanging connections with brain-dead browsers. Use
            #    this only for browsers where you know that their SSL implementation
            #    works correctly.
            #   Notice: Most problems of broken clients are also related to the HTTP
            #   keep-alive facility, so you usually additionally want to disable
            #   keep-alive for those clients, too. Use variable "nokeepalive" for this.
            #   Similarly, one has to force some clients to use HTTP/1.0 to workaround
            #   their broken HTTP/1.1 implementation. Use variables "downgrade-1.0" and
            #   "force-response-1.0" for this.
            BrowserMatch "MSIE [2-6]" \
                    nokeepalive ssl-unclean-shutdown \
                    downgrade-1.0 force-response-1.0
            # MSIE 7 and newer should be able to use keepalive
            BrowserMatch "MSIE [17-9]" ssl-unclean-shutdown


        • FWIW, after I created a self-signed certificate, I tried to run Let's Encrypt and got the following error message. Do I need to somehow remove the self-signed cert?

          Perhaps the problem is that I'm using Cloudflare? Is there a special setup for that?

          Failed authorization procedure. (tls-sni-01): urn:acme:error:tls :: The server experienced a TLS error during domain verification :: Failed to connect to for TLS-SNI-01 challenge


          • The following errors were reported by the server:

          Type: tls
          Detail: Failed to connect to for TLS-SNI-01

          To fix these errors, please make sure that your domain name was
          entered correctly and the DNS A record(s) for that domain
          contain(s) the right IP address. Additionally, please check that
          you have an up-to-date TLS configuration that allows the server to
          communicate with the Certbot client.

          • Yes, if you are using cloudflare it can certainly throw a spanner in the works...

            It is best to disable cloudflare until you have everything set up and working, and then turn it on, otherwise you won't always be seeing the changes you make in real-time (since it caches your website and displays the cached versio)

First of all, you can get green padlock with a self-signed certificate. Browsers will always going to trow an insecure connection error.

And about the redirect error, try adding these to wp-config.php

define('FORCE_SSL_ADMIN', true);
if ($_SERVER['HTTP_X_FORWARDED_PROTO'] == 'https')

If you still can't figure it out, get help configuring SSL here.

  • Yes, you can get a green padlock with a self-signed cert, but if the OP is going through all the trouble of setting up SSL, why not use a valid certificate?

Have another answer? Share your knowledge.