Question

can't ssh to my droplet with error Permission denied (publickey,gssapi-keyex,gssapi-with-mic)

Posted August 7, 2019 16.4k views
DigitalOcean

one day, I can’t ssh to my droplet with error Permission denied (publickey,gssapi-keyex,gssapi-with-mic), i have tried to re-add ssh key but the issue is not fixed. I need your helps!!!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
3 answers

Hi tungnguyenmr,

You would need to enter with your VPS with the password first though. Then edit the /etc/ssh/sshd_config with

PasswordAuthentication yes

Save the file and reload the configuration

service sshd restart

A more in depth answer can be seen here - SSH Key Permission deny

If the issue is still experienced, can you please try to ssh with the verbose command in order to see where the connection fails.

ssh -v  root@xx.xx.xx.xxx

Kind Regards,
Kalin D.

I found similar problem where the ‘Add SSH Keys’ dialog does not update the ’.ssh/authorizedkeys’ file for root. This must be done manually. However a separate issue is that the DO Console opens a terminal browser window that has a short copy/past buffer (~128bytes). From the terminal window run nano ’.ssh/authorized_keys’ for root, and update the rsa key by repeating copy/paste multiple times until the entire rsa key value is copied

Hello there,

You can check our article on How to Upload an SSH Public Key to an Existing Droplet

https://www.digitalocean.com/docs/droplets/how-to/add-ssh-keys/to-existing-droplet/

You can access the droplet from the DigitalOcean console and then temporary enable the PasswordAuthentication on your droplet and access the droplet with a password to upload the ssh-key.

If you haven’t created new pair of keys you’ll need to do that first.

You can enable PasswordAuthentication for your Droplet by modifying your /etc/ssh/sshd_config file. Once set to Yes restart the SSH service and connect via an SSH client for a more stable connection. You can then modify your ~/.ssh/authorized_keys file to add the appropriate public key.

This change can be made from the DigitalOcean’s console. If you’re having issues accessing the console you can then reach to our amazing support team that can help you further with this.

To enable the PasswordAuthentication follow these steps:

  1. Login to the console on the DigitalOcean website.
  2. Type sudo nano /etc/ssh/sshd_config
  3. Change PasswordAuthentication from “no” to “yes” and save the file
  4. Open a terminal on your computer and type ssh username@[hostname or IP address] or if on a Windows box use PuTTY for password login making sure authentication parameters aren’t pointing to a private key
  5. Login with a password
  6. Type sudo nano ~/.ssh/authorized_keys
  7. Paste public key text here and save the file
  8. Type sudo nano /etc/ssh/sshd_config
  9. Change PasswordAuthentication from “yes” to “no” and save the file
  10. Log out and attempt to log back in (if using PuTTY make sure you set up auth parameters to point to your private key)

You can then upload the key using this command:

ssh-copy-id -i ~/.ssh/mykey user@droplet

Hope that this helps!
Regards,
Alex