issvor
By:
issvor

Can't ssh to my VPS

November 2, 2016 138 views
Configuration Management CentOS

Using CentOS 7.2 x64
On Oct 31, my friend called me saying "Something happened to DigitalOcean, I had to restart my server and your teamspeak isn't up." I get home and check on my VPS. It shows that it's running, try connecting to my teamspeak and my website, both down. I try connecting through PuTTY, I get a "Network error: Connection timed out". I can only connect through the browser terminal on DO. I did a ssh server connectivity test on port 22 and it says that it can't connect.
Everything was fine before this. I'm not sure what to do.

1 Answer
xMudrii November 2, 2016
Accepted Answer

Did you tried to ping something from Web Console so you verify that it have network connectivity?

You can try server reboot if you didn't already:

  • sudo reboot

Do you remember changing any settings, like enabling firewall or something other?
For example, to verify ufw firewall status:

  • sudo ufw status

If it's enabled, you should see list of apps and make sure SSH and TeamSpeak (or their ports) are there

  • Hi, sorry for the late reply. I rebooted plenty of times but it didn't help any, I haven't changed any settings at all. Once I got my VPS setup to run my website, I stopped messing with it. All I did was update the page, and that's it. I tried the "ufw status" and it's telling me the command is not found

    • About ufw status - command not found, this is correct. I overlooked tags, on CentOS, ufw is not installed so it's not a problem.

      But thing you didn't tell me is do you have the Internet connection on Droplet. If you go to DigitalOcean Browser terminal (console) and execute:

      • ping google.com -c 3

      or any other like:

      • ping digitalocean.com -c 3

      it should return you something in line of:

      PING digitalocean.com (some-ip) 56(84) bytes of data.
      64 bytes from some-ip (some-ip): icmp_seq=1 ttl=56 time=28.3 ms
      64 bytes from some-ip (some-ip): icmp_seq=2 ttl=56 time=28.3 ms
      64 bytes from some-ip (some-ip): icmp_seq=3 ttl=56 time=27.0 ms
      
      --- digitalocean.com ping statistics ---
      3 packets transmitted, 3 received, 0% packet loss, time 2002ms
      rtt min/avg/max/mdev = 27.090/27.899/28.304/0.572 ms
      

      This is correct output, anything not like this means that you have a problem with connectivity.
      Basically best bet for this problems are DigitalOcean Support. They are epic guys who will assist you if your Droplet got cut from the Internet from some reason. :)

      • Sorry, I got a lot going on atm.
        I just tried pinging google.com and it came back with

        ping: unknown host google.com
        

        I'll head over to the DO Support. I really appreciate the help, man.

Have another answer? Share your knowledge.