Cannot enable mod_rewrite on centos7

I just fired up a CentOS7 Droplet. Then installed LAMP stack by following these instructions:

I see the “Testing 1,2,3…” page when I visit my server’s IP address, so I assume everything to be working fine. However, when I try to enable mod_rewrite, I see the following error:

[user@server conf]$ sudo a2enmod rewrite [sudo] password for user: sudo: a2enmod: command not found

What am I doing wrong? After much searching I found this Apache help document but it’s just way over the top for me to understand:

Any help offered would be greatly appreciated.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hey there,

a2enmod is a Debian/Ubuntu command. You’ll need to edit the Apache config file for a CentOS LAMP server.

What you’d want to do is edit the /etc/httpd/conf/httpd.conf file and make sure that the AllowOverride flag for the <Directory "/var/www/html"> block is changed from None to All.

Basically it should be something like this: (Note: there are many comment lines in the default httpd.conf file)

<Directory "/var/www/html">
Options .....
AllowOverride All

Happy coding,

Jon Schwenn Platform Support Specialist DigitalOcean