Cannot Kill process

I’ve tried all sorts of kill commands. When I go sudo netstat -lpn | grep :3000 I get a PID for a process. I kill it an another one immediately appears. I’ve tried every command I found on stack overflow and nothing can kill it.

Is there a way to wipe my droplet? I just started it so this would be easier then spending any more time trying to debug this.

This all stems from the inability to run my node app, but I believe this will be the first step to solving the larger issue.

Show comments

Submit an answer
Answer a question...

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

I found this that finally killed it killall -s KILL node . Maybe specific to this case, I don’t know. No other kill commands worked. Thanks for the reponses~

Perhaps search for node:

grep node -r /etc/systemd/system

And pm

grep pm -r /etc/systemd/system


It’s likely your nodejs is running as a service in /etc/systemd/system and so systemd restarts it the second you kill it (it’s made to restart automatically). So check /etc/systemd/system for nodejs services:

systemctl |grep node

grep "3000" -r /etc/systemd/system/

If it’s there you can stop it or disable it:

systemctl stop <service>
systemctl disable <service>