Question

cannt connect to kibana...

the errors"Upgrade Required Your version of Elasticsearch is too old. Kibana requires Elasticsearch 0.90.9 or above."&&“Error Could not reach http://10.30.13.6:80/_nodes. If you are using a proxy, ensure it is configured correctly”,could someone help me to solve the problems?? centos7 kibana4.1 I just follow this tutorial “https://www.digitalocean.com/community/tutorials/how-to-install-elasticsearch-1-7-logstash-1-5-and-kibana-4-1-elk-stack-on-centos-7

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

As the error message indicates, the version of Kibana requires Elasticsearch >= 0.90.9. If you follow that tutorial, you should have Elasticsearch 1.7 installed. Ensure that you have correctly added the repository. The file /etc/yum.repos.d/elasticsearch.repo should look like:

/etc/yum.repos.d/elasticsearch.repo
[elasticsearch-1.7]
name=Elasticsearch repository for 1.7.x packages
baseurl=http://packages.elastic.co/elasticsearch/1.7/centos
gpgcheck=1
gpgkey=http://packages.elastic.co/GPG-KEY-elasticsearch
enabled=1

You can verify the version of Elasticsearch by running the command yum info elasticsearch The output should look like:

$ yum info elasticsearch
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.solarvps.com
 * epel: ftp.osuosl.org
 * extras: ftp.osuosl.org
 * updates: mirror.atlanticmetro.net
Installed Packages
Name        : elasticsearch
Arch        : noarch
Version     : 1.7.5
Release     : 1
Size        : 30 M
Repo        : installed
From repo   : elasticsearch-1.7
Summary     : elasticsearch
License     : (c) 2009
Description : Elasticsearch - Open Source, Distributed, RESTful Search Engine