Question

CertBot apache issue

I basically hit this issue after following the apache -> ubuntu 17.10 setup

Error while running apache2ctl configtest. Action ‘configtest’ failed. The Apache error log may have more information.

apache2: Syntax error on line 226 of /etc/apache2/apache2.conf: Syntax error on line 33 of /etc/apache2/sites-enabled/000-default-le-ssl.conf: Could no t open configuration file /etc/letsencrypt/options-ssl-apache.conf: No such file or directory

So its missing a file but what should I do? Just create a blank file?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hey friend,

In this case removing certbot removed files that were referenced in the Apache configurations. You’ll need to clean them out. Try moving /etc/apache2/sites-enable/000-default-le-ssl.conf to another location (/root is fine) and restarting Apache.

Jarland

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I am facing some issue to migrate the website 192.168.l.1 on digital ocean from namecheap… Please help me to move the website with all paths same as…

"In an effort to provide customers with the best hosting experience possible, we have made the decision to take eHost offline and begin directing visitors to our partner brands. Over the next few months, we’ll be transitioning customers to a new platform that delivers a better experience and outstanding support. "

I’d start looking at a new host.

Resolved, had to update ubuntu :)